Hello Guest it is February 25, 2021, 06:13:07 AM

Author Topic: Mach3 Home switch question  (Read 3143 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Home switch question
« on: June 07, 2016, 01:28:40 AM »
Hello,

I am new to the world of cnc and I am learning as I go.I have a Chinese made machine that I am helping someone change over from a paralell BOB to an XHC Mach3 USB card.I managed to get it all wired up and working,but I still have some things to figure out/learn.
I can do the refhome function and x,y and z all go to the home position and stop.They do not reverse and come back off the switch.If I check the boxes to use them as limit switches also,the machine goes into limit estop right after homing.I think they are proximity or optical switches.A metal tab approaches them and triggers.The also have an led indicator on them,to show when they are activated.
Is there another setting or adjustment I should be looking at?
Thanks
Alan
Re: Mach3 Home switch question
« Reply #1 on: June 08, 2016, 04:29:08 AM »
Hi algba,
been quite awhile since I setup my home switches but on the 'home/limits' config page the 'home off' setting is used
to cause the axis to back off a specified amount,

Craig
My wife left with my best friend...
     and I miss him!

Offline Davek0974

*
  •  2,606 2,606
    • View Profile
    • DD Metal Products Ltd
Re: Mach3 Home switch question
« Reply #2 on: June 08, 2016, 06:56:37 AM »
When you do the ref-all function do the LED's on the sensors remain lit?

Sometimes with proximity sensors you cannot see the axis move off as the distance can be very small.

The LED should be off when homing is finished.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 Home switch question
« Reply #3 on: June 08, 2016, 07:36:17 AM »
Quote
been quite awhile since I setup my home switches but on the 'home/limits' config page the 'home off' setting is used
to cause the axis to back off a specified amount,

No, that's not what Home Off does.
Home Off specifies the location in machine coordinates of the home switch. The machine will only back off the switch until the switch opens, and no more.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 Home switch question
« Reply #4 on: June 08, 2016, 10:05:41 AM »
No the lights do not go out on the sensors unless I jog off of them,and it is a noticeable amount of movement.I do not have any limits enabled ,only home switch.
Re: Mach3 Home switch question
« Reply #5 on: June 08, 2016, 10:31:12 AM »
What version of Mach are you using?  When I initially set up my machine I used .066.  Every time I attempted to home the axis would blow through the limits and crash the machine.  Finally reloaded Mach and everything worked as it should. 
Tom
Re: Mach3 Home switch question
« Reply #6 on: June 08, 2016, 10:43:58 AM »
I'm using version R3.043.066.
all axis stop @ home ok ,and I can use the machine otherwise,but cant  use the limit switch function as it would immediately trigger and I would have to reset and manually jog off.There is only 1 switch per axis
Re: Mach3 Home switch question
« Reply #7 on: June 08, 2016, 10:51:07 AM »
I'm only suggesting that reloading Mach may cure your problem.  It did for me.  Version .066 has some issues and many others have suggested V.062 is a better option.
Tom

Offline Davek0974

*
  •  2,606 2,606
    • View Profile
    • DD Metal Products Ltd
Re: Mach3 Home switch question
« Reply #8 on: June 08, 2016, 02:52:16 PM »
Try adding some debounce in general config i think, maybe 2500 and try again with the limits, if it works reduce the value and keep trying until it fails then up it a bit.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Mach3 Home switch question
« Reply #9 on: June 08, 2016, 03:39:48 PM »
already tried debounce setting with no change.