Hello Guest it is January 27, 2022, 06:33:06 AM

Author Topic: Constant Velocity (CV) Mode Resulting in Jerky Motion  (Read 2138 times)

0 Members and 1 Guest are viewing this topic.

Constant Velocity (CV) Mode Resulting in Jerky Motion
« on: June 03, 2016, 12:49:24 PM »

I retrofitted a knee mill a while back. Most of my GCode has been fairly simple geometry and it has been working fine. Today I am working on a very complex mold machining so true 3-axis machining made of polylines (almost 200,000 lines of g-code per operation). I could not get through more than about 10 minutes of machining, sometimes much less, without the gecko drives disengaging presumably due to over acceleration.

I am using Sprutcam9. I manually edited my g-code file to add G64 to turn on constant velocity. It really smooths things out for the most part but also seems to have some very abrupt jerky accelerations and it does not seem to help with the disengaging problem any. On the Mach3 Settings page I have CV Distance and CV Feedrate turned off. Is there a difference between posting a G64/61 and the CV/Exact Stop setting in the General Logic Configuration page? Side question, does anyone know how to get Sprutcam to post G64? I can't find a setting anywhere that allows you to do this. Also, will anything other than G61 turn it off i.e. if I have G64 at the top of the file it should stay on for every case except a G61 right?

Here are the specs on my machine:
-Mach3 version 3.043.066
-KFLOP software version 4.33
-Kent KTM 380 Knee mill
-HEDS-5640-A06 500 countquadrature encoders https://www.digikey.com/product-deta...025-ND/1990423
-Gecko G320X Servo Drives
-0.2" / rev ball screws
-Belt reduction (two - one) from servo to ballscrews
-KL34-180-72 Servos http://www.automationtechnologiesinc...wed-rear-shaft

I read somewhere on a forum someone said that when Mach3 is in CV mode that it can increase the acceleration limits by 100%. Is this really the case? If so this really needs to be fixed as it seems to have some really nasty side effects. If this is the case it explains what I have been seeing. That is I set the acceleration limits based on what felt right when jogging. For most GCode moves the acceleration seemed to adhere to the acceleration limit I set. However, when running a lot of short polylines with CV on the acceleration seemed very noticeably higher. So to get around this I bumped my acceleration down to 2in/s^2. Alarmingly slow but its running my part with no problems so far....

It is really unfortunate that Mach3 has infinite jerk. KMotionCNC runs so much better than Mach3 when you tune down the jerk setting(in/s^3)!. The problem is I can't use my jogging pendant and probe with KMotionCNC. Is there any way to get Mach3 to adhere to the Kflop jerk setting? I'm guessing this is all on the Mach3 side.