Hello Guest it is November 22, 2019, 05:57:35 PM

Author Topic: No Motor Movement When Running GCode  (Read 2189 times)

0 Members and 1 Guest are viewing this topic.

No Motor Movement When Running GCode
« on: June 02, 2016, 02:05:10 PM »
Hi,
I've been having a series of issues today and can't seem to get to the root of the problem. I went to run my GCode and got an error "external estop requested." I switched the estop active low in pins and ports to fix that, then I was getting an error "machine out of limits for soft limit activation." I had to enable auto limit override in settings to fix this. At this point I again attempted to run my code. I can see the computer stepping through my software, the xyz axes are changing values, and the coordinate system that shows my path shows spindle movement. But the actual motor doesn't budge. I tried messing with soft limits again in case it thought it was past the limit, and finally turned all limits off, but to no avail. The hand controller works perfectly. I'm pretty sure I have some settings awry somewhere and the machine seems to be out of sync with the computer. What can I do to fix this?

Caleb

Offline Tweakie.CNC

*
  • *
  •  8,009 8,009
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: No Motor Movement When Running GCode
« Reply #1 on: June 03, 2016, 02:14:48 AM »
We need some more details about your system.

Type of machine ?
Are you using the Parallel Port or an external Motion Controller ?
Make & Model of the machine controller ?
Which version of Mach3 are you using ?

And any other details you think may help us to identify the problem.

Tweakie.

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline rcaffin

*
  •  1,003 1,003
    • View Profile
Re: No Motor Movement When Running GCode
« Reply #2 on: June 03, 2016, 07:58:14 AM »
One could suspect perhaps that there might be a fault on your eStop line. It may also be locking out your motor drivers.

Cheers
Roger
Re: No Motor Movement When Running GCode
« Reply #3 on: June 03, 2016, 10:51:16 AM »
I'm running a CNC machine: the JY5300-2 by MIB Instruments. The external hand controller is working fine, but I'm getting the errors I described when trying to run GCode in Mach3 - I guess that is parallel port.
How would I test the eStop line and the motor drivers?

Thanks,
Caleb

Offline Tweakie.CNC

*
  • *
  •  8,009 8,009
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: No Motor Movement When Running GCode
« Reply #4 on: June 03, 2016, 11:27:26 AM »
Looks like that controller does use the parallel port. As your hand controller is working fine then there is a good chance that you just have one (or more) of the Mach3 parameters incorrectly set.

Could you attach your .xml file, it is named <your profile>.xml (typically Mach3Mill.xml) so we can check your settings. This file needs to be copied from your Mach3 folder, renamed to something unique (calebfrome.xml) and attached using the Additional Options tab.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: No Motor Movement When Running GCode
« Reply #5 on: June 03, 2016, 11:34:50 AM »
Here's the xml.

Caleb

Offline Tweakie.CNC

*
  • *
  •  8,009 8,009
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: No Motor Movement When Running GCode
« Reply #6 on: June 03, 2016, 11:54:34 AM »
Your .xml file does not have any of the required parameters set. Section 5.2 of the Mach3 manual (http://www.machsupport.com/help-learning/product-manuals/) explains the settings that need to be made and you will need to refer to your controller manual to establish which pins they use for the various axes step and direction.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.