Hello Guest it is July 20, 2019, 04:12:10 AM

Author Topic: Feed rate over ride problem  (Read 2688 times)

0 Members and 1 Guest are viewing this topic.

Feed rate over ride problem
« on: May 28, 2016, 10:06:46 AM »
Hi

I’m hoping someone can offer some pointers to help me solve a feed-rate problem I am having. I have a 600x400 CNC router running Mach 3 (Version 2.63) and my PC has a 32-bit Win7 OS.

The problem is with the feed-rate seems to be locking itself down to 2% of the set value and is constantly saying it is over ridden.

Observations:
My PC is not connected to the CNC and I load some G-code with a feed rate of 732mm/min and run the programme. The set feed-rate can be seen as set at 732mm/min by the code – the actual feed-rate can be seen following the set feed-rate more or less. There is no Feed-rate over-ridden LED lit up.  – in other words -  it behaves normally.

I then try the same thing when connected to the CNC. When the machine is connected the software always flashes the feed-rate over-ridden LED – it indicates a 2% FRO in the top right corner of the Feed rate box. The feed rate creeps along at a fraction of the 732mm/min in the code (2%?) . If I press the reset button whilst running the feed-rate momentarily speeds up to the target value but then resets back down again. The reset button and the up and down buttons have no persistent impact. They do work however if I am not connected to the CNC.

It kind of feels like I have a setting somewhere that is forcing the feed-rate down when connected to the machine. I can’t for the life of me find it however.

Any suggestions on what to look at to get this running correctly please? Any suggestions greatly appreciated.

Thanks

Andy

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate over ride problem
« Reply #1 on: May 28, 2016, 11:02:29 AM »
Are you connecting the PC to the machine using the Parallel Port or are you using a motion controller ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Feed rate over ride problem
« Reply #2 on: May 28, 2016, 11:32:04 AM »
I'm connecting to the machines control box that has a motion controller and the connection is via a USB.

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate over ride problem
« Reply #3 on: May 28, 2016, 11:49:35 AM »
What is the make of the motion controller you are using ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Feed rate over ride problem
« Reply #4 on: May 28, 2016, 04:09:55 PM »
The machine is a X6-1500GT by www.cnc.carving.com.

Its a basic 600x400mm Chinese router.

The controller is titled "Xulifeng-Mach3-USB-Motion-Card" - See also image attached.

Link here to manufacturers website:

http://www.omiocnc.com/x6-1500gt/


Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate over ride problem
« Reply #5 on: May 29, 2016, 01:27:01 AM »
You are using a very old version of Mach3 and I suggest you should be using a later version. The most popular version appears to be R3.043.062 and this can be downloaded from here;
http://ftp://anonymous:guest@machsupport.com/Mach3/Mach3Version3.043.062.exe
Keep a copy of your <your profile>.xml file and load the new version of Mach3 over the top of the old.

Check that you have configured Mach3 and the plugin correctly by going through the AKZ250 manual again, step by step. Mach3 USB Motion Card AKZ250 Installation Manual Pay particular attention to Section 6 (Feed rate, spindle speed rate, or jog rate can by controlled by the adjustment-knob).

Download and install the latest version of the plugin driver (the old version needs to be deleted before installing the new). http://leafboy77.com/index.php/en/home/16-english-categories/mach3/usb-motion/card-akz250/1-mach3-usb-motion-card-akz250

If this fails to resolve the problem then attach your <your profile>.xml file so we can check your Mach3 settings. This file needs to be copied from your Mach3 folder, renamed to something unique (andyboy.xml) and attached using the Additional Options tab.

Hope this helps (I am assuming I have identified the correct motion controller attached to your machine).

Tweakie.
« Last Edit: May 29, 2016, 05:52:36 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Feed rate over ride problem
« Reply #6 on: May 29, 2016, 11:25:28 AM »
Many thanks for the reply. I will try this and report back.

Before I do so I have tried one more thing, which was as follows. I have another PC - running the same version of Mach 3 and on Windows XP OS.

Used this PC to drive the CNC and it behaved normally - i.e. the FRO is not locked down to 2%.

My thinking was - how can I compare the settings on the XP laptop / Mach 3 (which works) with the settings on the Win7 laptop (which has the problem)?  - it may be that this could identify some differences that might explain the issue.

With regards to the xml file that defines my profile. In my c:Mach3 folder I have a text document called profile.txt. When I open this the content says "Mach3Mill". It this same folder there are 3 files that have an xml extension. One is called - Mach3Mill.xml - is this my profile or xml file that I see referred to in various posts?  (sorry if this is a really basic question).

Andrew
Re: Feed rate over ride problem - with resolution
« Reply #7 on: May 29, 2016, 12:34:22 PM »
OK. I have discovered the root cause and fixed it.

It was a simple config change on the motion card set up.

in config / config plug-ins - I selected the motion card (yellow box) with the CNC connected to the PC. I changed the setting for the Ratio FRO% from "external" to "internal".

The override controls immediately took effect in my session of Mach 3 and normal control was resumed. I ran the G-code file I'd been experimenting (learning) with and it ran beautifully with the correct feed rates and I was able to adjust the feed rate using the normal FRO controls in the programme.

I'm not sure exactly what its done but I think that with the setting on "external" the program allows an external control of feed rate using a knob on the CNC control box. This seems to have been locking out the ability to allow Mach 3 controls in the programme to do so. Now its set on "internal" it is not looking for an external input to the FRO. Does that sound logical?

In any case - I'm up and running.

Would you still recommend I upgrade to 3.043.062 ?

Andrew
 

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate over ride problem
« Reply #8 on: May 30, 2016, 01:46:47 AM »
Hi Andrew,

I am pleased that you have it working.  :)

Just my opinion...

If it's working OK then leave it as it is.

At some later date (perhaps after you have gained more experience) you may find that some functions do not work as expected and that's the time to change to the later, more up-to-date, version.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Feed rate over ride problem
« Reply #9 on: May 30, 2016, 07:07:12 AM »
Thanks Tweakie, I agree, I'll leave alone for the time being and concentrate on learning.

Next job is to set up my flood coolant system on the machine.

Thanks for the help.

Andrew