Hello Guest it is October 18, 2019, 01:23:40 PM

Author Topic: Can't get servos to move  (Read 9072 times)

0 Members and 1 Guest are viewing this topic.

Can't get servos to move
« on: April 21, 2016, 02:24:44 PM »
I'm currently retrofitting a large chinese CNC. I've replaced the chinese motion controller with Vitalsystems' DSPMC and Mach 4.

Here's the problem: I can't seem to get the servos working properly, if at all.

Here's what I'm working with:
Mach 4
DSPMC/IP with 3 pn7535 boards, 1 pn7737 board and 1 pn7711 board. The 7737 connected to J12 and configured for that in the VSI Manager.
Yaskawa SGDM-ADA servo drivers, 4 of them(X,Z,Y x2)

The symptoms of the issue are rather weird and inconsistent. After physically connecting everything a described in Vitalsystems' manuals and configuring everything as described and as I thought to be correct, I tried getting the servos to move using jog mode in Mach 4. Of course, it didn't work. After a lot of troubleshooting I finally traced it to inconsistent step/dir signals from the motion controller. In order to have a reference, I quickly connected up the old chinese motion control system, and had a look at the step/dir signals using an oscilloscope. The chinese one could move the servos without problems, despite the horrible ringing of the step signal (before you ask, it was using the same position control mode and the same signals to control the servo driver). It was very responisve to jog commands, the signal's frequency changed as it should, accounting for proper, smooth acceleration. The direction signal changed as it should, without any delays. In contrast, after hooking up the oscilloscope to the signals generated by the DSPMC, the signals were horrible in their content. The signals were incredible in actual signal fidelity (if they actually were there), the edges were fast and there was no ringing, even though the total cable lenght from the DSPMC to my probes was way over 3 meters. The horribleness was the signal's content. Sometimes, the first movement command (from a standstill to a complete stop) was perfect, only to be followed by a step signal without proper acceleration, no respective change in the direction signal, nothing, or total garbage. The last being rather infrequent, possibly not being caused by the main problem but something else. The direction signals was jerky too, it sometimes didn't change at all, sometimes too late. Same with the step signal, it just wasn't there at times. But here comes the even weirder thing: the first movement wasn't always there, requiring re-enabling of Mach 4 to come back, and only using step/dir channel SG5 of the DSPMC. I can't really recall what happened on the other channels besides SG5 when probed.

The power supply GND is connected to the chassis, and therefore to mains earth. The total cable lenght from the DSPMC is about 1.8 meters (1.2 from the DPSMC to the 7737, and 0.4 from there to the driver). The cable lenght shouldn't be the issue here, since the signal integrity was great, even after using a longer, 1,5m ethernet cable for probing (which adds up to about 3m total). Induced noise from the 380V stuff around the electrical cabinet, maybe. Since it was a retrofitting project, there was no efficient way of separating things as good practice might advise to. Still, the signal was quite clean of noise.

I tried using an example g-code to rule out the jog mode being at fault. It did a little better, now doing 2 proper moves and then sometimes leaving the servo moving at a low speed. It still failed to move it after these two though. I also modified the motor's acceleration curve to be a little less steep.

Could it be caused by the fact that I haven't yet applied the license key to Mach 4? I have one, but I'm not going to apply it until the machine's working if not necessary.

The computer's quite a beast, 4 core i5 2400, and 4GB of RAM. That can't be the limiting factor, unless something's incorrectly configured. Did a clean install of win 7 pro, and it hasn't got an internet connection, so Mach4 shouldn't be interfered with either.

Some screenshots of the config windows I though could be useful:
https://drive.google.com/file/d/0B_yAWIhEioTZS2N5ZXlfb1duaU0/view?usp=sharing
https://drive.google.com/file/d/0B_yAWIhEioTZcFFGNGc1cDN0cDg/view?usp=sharing
https://drive.google.com/file/d/0B_yAWIhEioTZclRpOXk5NTl1SHc/view?usp=sharing
https://drive.google.com/file/d/0B_yAWIhEioTZREt6NlgzYUVEMlE/view?usp=sharing
https://drive.google.com/file/d/0B_yAWIhEioTZUnVtamNsOWtHSUk/view?usp=sharing
https://drive.google.com/file/d/0B_yAWIhEioTZQzY0UG1UOHp0Q0U/view?usp=sharing
Re: Can't get servos to move
« Reply #1 on: April 21, 2016, 03:49:19 PM »
hi,  can you also share the DSPMC status window so we can see the version numbers on the top left corner.  Also, we added a section for proper earth grounding at the end of the user manual.  pls review that to make sure electrical noise is not effecting the system.  You can also send us your mach4 profile to the support email so we can replicate the system here and make sure proper step signals are generated.  Thanks.

VSI Support.
Re: Can't get servos to move
« Reply #2 on: April 25, 2016, 03:34:43 PM »
Hello,

I checked your Mach4 profile and here are the things I can think of:

- Because you had ordered one 7737 board, we set the DSPMC to use J11 (or P13 in MAch4) as the port for the 7737. Plug your 7737 board into J11 and use Steppers 0 - 3
- Try using the profile that I've attached here. It ought to work as long as you plug the 7737 into J11. Provided your wiring is all good with the 7737, you can enable Mach4, which should enable your drives, and you ought to be able to jog the XYZA axes

Let me know if you see any issues.


-Marc
Vital System Inc.