Hello Guest it is September 20, 2019, 08:41:11 AM

Author Topic: How to disable E-Stop on Limit  (Read 1931 times)

0 Members and 1 Guest are viewing this topic.

How to disable E-Stop on Limit
« on: March 19, 2016, 10:41:01 AM »
Hello!

I have retrofitted an early 80's 18kW CNC Lathe with Mach3, Panasonic Servos and CSMIO.
I have got nearly everything working, but i have the following issue:

My Lathe has got professional "Euchner" Limit+, Limit-, E-Stop and Home Switches.
That means, when the Machine is on the Limit it does not have to trigger the E-Stop, because the E-Stop button is a few Millimetres later.
(And the E-Stop is connected to the Pilz Safety Module, so its really safe)


I want to use the "hard" Limits because eg. before Ref. drive the Soft Limits are in the wrong place.


Is there an Option without Brains and Macros?


Yours loisftw

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: How to disable E-Stop on Limit
« Reply #1 on: March 19, 2016, 12:06:34 PM »
I'm only guessing here but if the limits are on one input and the home on another, it should work ok?

My stuff has combined limits and homes and that works how i expected it to.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: How to disable E-Stop on Limit
« Reply #2 on: March 19, 2016, 01:01:45 PM »
Exactly, each Axis has it own Input for Limit+, Limit- and Home.
The E-Stop Limits are connected in series and then to the Pilz Module.

Offline Hood

*
  •  25,850 25,850
  • Carnoustie, Scotland
    • View Profile
Re: How to disable E-Stop on Limit
« Reply #3 on: March 19, 2016, 03:05:23 PM »
If I am understanding you, there are limits and homes and they are separate and wired up to the CSMIO individually. If that is the case what are you expecting should happen when your machine hits the limit switch?Hood
Hood
Re: How to disable E-Stop on Limit
« Reply #4 on: March 19, 2016, 09:02:40 PM »
Yes! The Limits should stop the axis moving in this direction, but should be movable wihout reset and the Override Buttons in the other direction.

Offline Hood

*
  •  25,850 25,850
  • Carnoustie, Scotland
    • View Profile
Re: How to disable E-Stop on Limit
« Reply #5 on: March 20, 2016, 04:14:35 AM »
Ok well not possible with Mach if they are set as Limit switches.
You have to press Reset after a limit is hit, nothing you can do about that.
You do not have to press the Override button however, you can choose Auto Limit Override on, I think, settings page and all you will have to do is press the Reset then you can jog off.

In reality if you have soft limits enabled then you should neve really hit limits.
On Startup Softlimits are not functioning until until referenced, for obvious reasons. What is best in that situation is make your home switches so that after they are triggered they stay triggered right to the extent of the axis. That way the CSMIO will see they are triggered when you first start up and instead of moving in the normal homing direction it will just do the Back Off move, that is the way it is set up on My Chiron VMC and Computurn Lathe.
Hood
« Last Edit: March 20, 2016, 04:16:08 AM by Hood »
Re: How to disable E-Stop on Limit
« Reply #6 on: March 20, 2016, 09:44:19 AM »
OK.

Thank you!

loisftw
Re: How to disable E-Stop on Limit
« Reply #7 on: April 02, 2016, 09:30:13 AM »
we had the same problem, thanks i got the answer here