Hello Guest it is May 21, 2019, 03:24:46 PM

Author Topic: Safe z question  (Read 1764 times)

0 Members and 1 Guest are viewing this topic.

Safe z question
« on: March 15, 2016, 08:03:03 AM »
I had my machine set up with a 1.5" safe z. When I hit the stop button on the mach3 screen it would raise the z to 1.5". Now I set up homing switches and when I hit stop it raises the z axis all the way to the top(homed position). Is there a way I can get it to only raise a small amount like it used to?  Also I am using the 2010 screenset.


Sent from my iPhone using Tapatalk

Offline ger21

*
  • *
  •  6,232 6,232
    • View Profile
    • The CNC Woodworker
Re: Safe z question
« Reply #1 on: March 15, 2016, 08:15:50 AM »
Your safest option is to setup safe z to use machine coordinates, and use a negative number like Z-2. That way you will always have the same SafeZ position.
Check your Config >Safe Z settings, and see what it's set to?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Safe z question
« Reply #2 on: March 15, 2016, 08:21:23 AM »
You have a few options for Safe Z, Machine Coords which I prefer as I always know exactly where it will go which I have set to -5 which means it will raise to 5mm before fully up.
There is also Incremental which will raise it up the value you entered from the position you are presently at.
You also have a Work Coords option, so say you have entered 5 for it then it will move to 5 in the work coordinate system.


Hood

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Safe z question
« Reply #3 on: March 15, 2016, 08:22:18 AM »
Man I must be getting really slow at typing now , Ger replied 5mins before I did LOL
Safe z question
« Reply #4 on: March 15, 2016, 01:22:55 PM »
You guys are great. I will try it tomorrow night.


Sent from my iPhone using Tapatalk
Re: Safe z question
« Reply #5 on: March 20, 2016, 06:13:33 AM »
It worked.  I had the safe_z setup wrong.  Changed it to -4 machine coordinates and it works great.  Thank you guys for your help.