Hello Guest it is June 27, 2019, 07:12:46 AM

Author Topic: Using servo for spindle on lathe  (Read 4052 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Using servo for spindle on lathe
« Reply #20 on: March 15, 2016, 07:59:26 PM »
BTW that is one of the annoyances I have about the SS and ESS. My spindle motors have Sine/Cosine encoders and work best when I have the encoder count interpolated and set high, the servo drive can really handle the motor smoothly but the ESS can not handle it as the pulse width is too great for the frequency so I have to lower the encoders resolution.

I thought I could get round it by using electronic gearing in the drive but that just caused other issues, whether ESS or Servo I am not sure but I would guess ESS. What would happen is when I commanded M5 it would sometimes run on for a few seconds and then all of a sudden stop without decelleration. A 250mm dia chuck stopping instantly is not good for the heart or the machine ;)

Hood

Offline Hood

*
  •  25,847 25,847
  • Carnoustie, Scotland
    • View Profile
Re: Using servo for spindle on lathe
« Reply #21 on: March 15, 2016, 08:00:13 PM »
Aye 11AM in Oz, 12PM is Scotland :D

Hood

Offline DMBGO

*
  •  186 186
  • You are young and life is long and there is time.
    • View Profile
Re: Using servo for spindle on lathe
« Reply #22 on: March 15, 2016, 08:03:34 PM »
Yes
I didn't have this issue with the CSMIO
Here are the working Ess settings for posterity.
Cheers

David