Hello Guest it is January 25, 2020, 03:08:16 PM

Author Topic: Silly little problems but they are bigger than me...  (Read 1567 times)

0 Members and 1 Guest are viewing this topic.

Silly little problems but they are bigger than me...
« on: March 08, 2016, 07:27:27 AM »
OK, so I'm a relative veteran of Mach3. About 11 years I think. But I'm also very focused on the products I make and have only learned enough to cope with a limited number of parameters. For anything else, well if I have to adjust something out of my payscale I creep in and flick the switch and then try and get out without bumping anything off the shelves.Now I am having a few issues with what should be straightforward things and I can't get my head around them.

Background; a year ago my computer died and a modern replacement turned out to not only not have a parallel port but not even be able to run one if you installed it. So I bought a Smoothstepper which was inserted into my controller by a relatively (700 miles) local genius type person. I then discovered I need to be running a much more recent version of Mach3 to run the Smoothstepper and ever since I have been a teeny bit lost.

I find when I read this board it pretty much all goes over my head. No-one seems to have tiny issues like mine.  

Issues;
1) if I go into the Config/Safe Z and set a safe Z height, and then exit and Config/save settings then it works with that setting until I close the program. When I come back next day it has always reset itself to 381.
2) if I press spacebar, which used to operate as a panic button (what, me panic..?) the feed will stop but not for about 3 seconds, ie. right through the fixture/flange/ etc. It used to be about 1/2".
3) although I have the machine set to metric in setup it often starts in imperial. Forgetting to check this and reset it has caused me real pain.

Can anyone help with these small things?

Best Wishes

Chris

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: Silly little problems but they are bigger than me...
« Reply #1 on: March 08, 2016, 08:02:14 AM »
Some of this sounds like a windows file permission issue, esp the not remembering t he setting, have a look in Documents and settings > user name > application data and see if there is a Mach3 folder in there.

It seems somehow that older apps save their data in their local program files folder but newer windows seems to say No! I'll save it in Documents and settings > user name > application data because I am windows and I am smart. The trouble is the app still looks in its own folder and thus can't find it!

May not be the issue here but you never know.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Tweakie.CNC

*
  • *
  •  8,106 8,106
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Silly little problems but they are bigger than me...
« Reply #2 on: March 08, 2016, 08:02:50 AM »
Hi Chris,

From reports of others I think you need to be running Mach3 R3.043.062 ( if you are not already doing so ).

1) I have no idea about the safe Z problem – Safe Z is not something that I use.

2) The Feed–Hold delay is related to the Smooth Stepper buffer size.

From the ESS doc...
A smaller buffer size is more responsive to Feed Hold commands, but more sensitive to the ESS running out of data if your computer gets bogged down. 
A larger buffer size is less likely to experience the ESS running out of data, but will take longer to respond to Feed Hold commands.

3) Again something I have no idea about – if Mach is set to metric then it should stay in metric (my installation of Mach3 does).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Silly little problems but they are bigger than me...
« Reply #3 on: March 10, 2016, 03:00:33 AM »
Thanks for the suggestions, I'll check them out...

Chris