Hello Guest it is May 21, 2019, 07:13:57 PM

Author Topic: Feed rate override encoder delay issue  (Read 975 times)

0 Members and 1 Guest are viewing this topic.

Feed rate override encoder delay issue
« on: March 01, 2016, 08:39:01 PM »
Hi,
I have setup the trial of mach3 with pokeys56u incl. plugin. My issue is that I have set up a rotary encoder to control the feedrate override and there seems to be a fair delay from encoder movement to physical change in the feedrate. The feed rate % on mach3 changes straight away though. I am using a pokeys56u with PoExtBusOC16CNC and postep 25/30 drivers
I hope someone can help.
Cheer
Brad
Re: Feed rate override encoder delay issue
« Reply #1 on: March 01, 2016, 09:13:01 PM »
Im not familier with the pokeys56u but guessing its another type of smooth stepper?? If so the problem is alot of moves have already been sent by mach and are buffered, have to wait for buffer to be used up before feed override or even feed hold to activate. See this thread i made a week ago about feed hold with smooth stepper: http://www.machsupport.com/forum/index.php/topic,31994.0.html

You might be able to adjust buffer to smaller size maybe?
Re: Feed rate override encoder delay issue
« Reply #2 on: March 01, 2016, 09:34:58 PM »
Im not familier with the pokeys56u but guessing its another type of smooth stepper?? If so the problem is alot of moves have already been sent by mach and are buffered, have to wait for buffer to be used up before feed override or even feed hold to activate. See this thread i made a week ago about feed hold with smooth stepper: http://www.machsupport.com/forum/index.php/topic,31994.0.html

You might be able to adjust buffer to smaller size maybe?

Thanks mmurray70, I will look into that tonight.
Does anyone know how to check and/or improve the usb signal quality? I know when I was testing mach4 pokeys had a usb test in the plugin and when I was running 2 axis simultaneously it was maxing out. I am already running the usb cables through a powered hub.
Cheers