Hello Guest it is May 15, 2021, 06:34:43 PM

Author Topic: Mach 4 freezes occasionally at spindle control  (Read 1661 times)

0 Members and 1 Guest are viewing this topic.

Offline Pedio

*
  •  200 200
    • View Profile
Mach 4 freezes occasionally at spindle control
« on: February 14, 2016, 01:51:55 PM »
Occasionally Mach 4 freezes when it encounters a spindle control. I can run the same G code file numerous times and Mach 4 will all of the sudden stop at a M03 command. The cycle start button will be grayed out. Sometimes I can disable Mach 4 and re-enable it to get the cycle start button to be slectable again. Sometimes this does not work so I have to reboot Mach 4 again. I am running build 2797 with SmartBob 33.159 plugin.

Anyone else having this problem? Any suggestions?

Offline DazTheGas

*
  •  753 753
  • DazTheGas
    • View Profile
Re: Mach 4 freezes occasionally at spindle control
« Reply #1 on: February 14, 2016, 04:08:13 PM »
Have you considered updating to the latest version of 2872 to see if the problem still exists

DazTheGas
Theres always time for a choccy biccy

Offline Pedio

*
  •  200 200
    • View Profile
Re: Mach 4 freezes occasionally at spindle control
« Reply #2 on: February 14, 2016, 04:48:14 PM »
I tried that version and had all sorts of problems. There is another thread on the problems. I went back to this version.
Re: Mach 4 freezes occasionally at spindle control
« Reply #3 on: February 14, 2016, 10:41:41 PM »
Occasionally Mach 4 freezes when it encounters a spindle control. I can run the same G code file numerous times and Mach 4 will all of the sudden stop at a M03 command. The cycle start button will be grayed out. Sometimes I can disable Mach 4 and re-enable it to get the cycle start button to be slectable again. Sometimes this does not work so I have to reboot Mach 4 again. I am running build 2797 with SmartBob 33.159 plugin.
Please post this issue on the PMDX support forums (http://www.pmdx.com/PMDX-Forums/), since you are running a PMDX-410 and PMDX-132.  The Machsupport forums are not our primary support venue, and this will get into plug-in and SmartBOB specific troubleshooting.

Bob