Hello Guest it is November 12, 2019, 06:55:38 PM

Author Topic: I cant get my feed calibrated in Inches yet mm works...  (Read 2000 times)

0 Members and 1 Guest are viewing this topic.

Offline TFT

*
  •  17 17
    • View Profile
I cant get my feed calibrated in Inches yet mm works...
« on: February 12, 2016, 12:11:28 PM »
I have a stepper motor that feeds an extrusion via roller on the x-axis.  If i change the units to millimeter and calibrate, the extrusion feeds fine.  "G00 X10" moves 10mm, however, when i change the units to inches and then calibrate the feed is way off.  More specifically, it moves at the velocity I want but the DRO is only going up by hundreds of an inch when its obviously moving faster. So you can see the result moves the part much farther than say 10 inches.

I've tried calculating "Mach3 steps per unit" and I get a similar number to the automatic calibration.  Also, when i change the steps per unit up or down it seems to make the problem worse.  I'm not sure what to do because i need this thing in inch units.

Thanks
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #1 on: February 12, 2016, 12:15:03 PM »
how exactly are you changing over to inches?  Setting the native units to inches?
Take your steps per in the metric settings and divide them by 25.4  tune motors.

Look in the settings page to see if your in inches or MM`s.

Make sure you code has either a G20 to set the machines code in inches or no G21 (sets the machine in mm`s) regardless of the native units.  You can have a machine setup in MM`s and use a G20 to run an inch Gcode

Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #2 on: February 12, 2016, 12:20:39 PM »
Here's the xml file

Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #3 on: February 12, 2016, 12:25:12 PM »
Here's the xml file

Yeah I change to inches on the setting page "Alt-6". 

I will try what you said.  thanks 

Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #4 on: February 12, 2016, 12:26:55 PM »
how exactly are you changing over to inches?  Setting the native units to inches?
Take your steps per in the metric settings and divide them by 25.4  tune motors.

Look in the settings page to see if your in inches or MM`s.

Make sure you code has either a G20 to set the machines code in inches or no G21 (sets the machine in mm`s) regardless of the native units.  You can have a machine setup in MM`s and use a G20 to run an inch Gcode

BTW I have no code i'm just enter in the MDI G00 X10

Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #5 on: February 12, 2016, 01:15:48 PM »
how exactly are you changing over to inches?  Setting the native units to inches?
Take your steps per in the metric settings and divide them by 25.4  tune motors.

Look in the settings page to see if your in inches or MM`s.

Make sure you code has either a G20 to set the machines code in inches or no G21 (sets the machine in mm`s) regardless of the native units.  You can have a machine setup in MM`s and use a G20 to run an inch Gcode

I have G20 set and I tried dividing my milimeter step per unit calibration by 25.4.  It still wont work right, I'm lost.
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #6 on: February 12, 2016, 02:14:41 PM »
If you work in INCHES, it's generally best to go to make your Native Units Inches in the config.
Then adjust your steps per, speeds and accels. accordingly in Motor Tuning.

Your XML shows that your native units were set to MM.  
At that point, all you needed to do (from 0) was MDI G20 X1 and you should have fed 1" of material.
And being your DRO's are not locked to the set-up units, the DRO would be indicating Inches.
MDI G21 X1 (from 0) you would feed 1mm and the DRO would be displaying mm's.

If you Lock the DRO's to setup units, the DRO's will always display the native units although G20 and G21 will move in inches and mm's respectively.

Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #7 on: February 12, 2016, 02:19:04 PM »
If you work in INCHES, it's generally best to go to make your Native Units Inches in the config.
Then adjust your steps per, speeds and accels. accordingly in Motor Tuning.

How do i set the native units to inches in the config?
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #8 on: February 12, 2016, 02:27:41 PM »
Up top, Config button, then Native units.



Offline TFT

*
  •  17 17
    • View Profile
Re: I cant get my feed calibrated in Inches yet mm works...
« Reply #9 on: February 12, 2016, 02:43:54 PM »
OK it seems to be feeding at the correct unit in inches now.  Thanks guys.