Hello Guest it is December 10, 2019, 02:11:22 AM

Author Topic: Homing setup  (Read 2209 times)

0 Members and 1 Guest are viewing this topic.

Homing setup
« on: March 05, 2016, 06:56:58 PM »
Hi
Finally have some time to set up my table. In motor home /soft limits I am trying to get my directions right with my axis's get my soft limits correct and to correlate with my screen view. If i go to my home on the table and zero every thing, on my Offsets screen the currant work offsets are not at zero. How do I reset, or is there a way I can start from scratch to set all this up.  I have been working on this set up a roadrunner shows up on the screen way out of my table view and my X and Y go out of my table view to run. I would like to start fresh on this setup but don't know how to get the right orientation.
My table is 24" in the Y and 96" in the X facing the table the long side in front of me I want my home to be bottom right hand corner
Any help is appreciated
Thanks Bill
Re: Homing setup
« Reply #1 on: March 05, 2016, 07:10:26 PM »
Hi
Just ref all to my home switches, and zeroed all, on my settings page the encoder position still has misc positions shown should I zero to the DRO here
Bill

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Homing setup
« Reply #2 on: March 05, 2016, 07:30:06 PM »
Quote
If i go to my home on the table and zero every thing, on my Offsets screen the currant work offsets are not at zero.

Because when you zero an axis, you're setting an offset for that axis, relative to the machine coordinates.

The only way to have your offsets stay at zero is to always work in machine coordinates, which means that you can never zero the axis except for homing.


Quote
Just ref all to my home switches, and zeroed all, on my settings page the encoder position still has misc positions shown should I zero to the DRO here

Unless you actually are using encoders, then just ignore them.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Homing setup
« Reply #3 on: March 05, 2016, 07:42:08 PM »
A question
When I ref home.My Z goes to the top of is movement hits the limit switch and backs of If I run the roadrunner program it does not go down to my work surface but stays at the upper position I thought I had set it correctly from the video. I am trying to get all these setting correct in homing and soft limits and have read the manual and watched the videos. It seems like I am missing some  logic to all this. I don't think this should be difficult.
Just trying to sort it out
Thanks Bill

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Homing setup
« Reply #4 on: March 05, 2016, 07:44:51 PM »
You need to jog the Z axis down until the tool just touches the work piece, and then zero the Z axis.

Generally, when you are machining parts, you are using a work offset. When you home the machine, you are setting the machine coordinates.
Z zero in machine coordinates is at the top of the Z axis travel.
Z zero in work coordinates is the surface of your part.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Homing setup
« Reply #5 on: March 05, 2016, 08:11:11 PM »
Maybe you just answered this, I am just trying to understand the setting directions when I home all and open the roadrunner now it open inside my work area shown on the screen bottom corner were I have homed. The problem I am having iis that if I run program the machine wants to go outside the table perimeters in both X and Y it is like the direction is set backwards. I keep going back to the Homing and limits page and try reversing or put in - settings but I just can't seem to find the right setting
Thanks Bill
Re: Homing setup
« Reply #6 on: March 07, 2016, 02:44:43 PM »
Hi
Sorry if I don't have the technical language yet to explain this. I am trying to set up my homing and limits in Mach3. here is what I am encountering. I have set my soft min  limits X is 96" and Y is 24" I can run ref home and the machine does fine. when I load the roadrunner g code to test, the machine tries to go away from the roadrunner image on my screen in both the Y and the X,  if I go to Homing and limit and uncheck the X and Y box , my machine will home to the opposite side of the table In X and Y when I load the roadrunner it will show were the machine has ref home. If I run roadrunner again the machine wants to go in both opposite directions of the image on the screen. I have tried entering my soft limits in the soft max that just changes my table orientation. I know I must have something backwards can't figure out what.
Thanks Bill