Hello Guest it is July 07, 2020, 03:51:22 PM

Author Topic: arcs gone wild  (Read 3576 times)

0 Members and 1 Guest are viewing this topic.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
arcs gone wild
« on: May 12, 2007, 03:55:11 AM »
Hi all

Has anyone come accross the problem of Mach3 getting the centre of G02 G03 arcs a country mile out? I have a simple toolpath to cut out a rectangular profile. Each corner (of the toolpath) is an arc which should have a radius of around 7mm according to the g-code. However Mach3 interprets the radius to be massive so I end up with a toolpath resembling a rectangle with huge "micky mouse" ears!!!

Sorry - can't seem to figure out how to attach images code etc...

Any comments, advice would be welcome.

Cheers

Offline Graham Waterworth

*
  • *
  •  2,102 2,102
  • Yorkshire Dales, England
    • View Profile
Re: arcs gone wild
« Reply #1 on: May 12, 2007, 04:00:47 AM »
Go into gen config and change the IJ mode, that should fix it.

Graham.
Without engineers the world stops

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: arcs gone wild
« Reply #2 on: May 12, 2007, 04:43:08 AM »
Many thanks Graham - problem solved - strange though, havn't had this happen before... Though I have just reloaded Mach3, but can't remember setting this before.

Anyway thanks again for your quick and spot-on reply

Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: arcs gone wild
« Reply #3 on: May 14, 2007, 04:29:54 AM »
And also don't forget your cam program can toggle this also.

Chad

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: arcs gone wild
« Reply #4 on: May 14, 2007, 05:14:16 AM »
thanks chad - right on the money.

I'd switched off "output arcs as linear segments" in my CAM (RhinoCAM) which meant this was the first time I'd actually posted a real arc (G02 and 3) so this was the first time Mach3 cared about this setting.

Thanks both for your help
Re: arcs gone wild
« Reply #5 on: January 21, 2008, 02:50:37 AM »
Thanks for this thread, I was having the same problem posting from Gibbs.   Switching the IL buttons fixed that.

Omega_Sam