Hello Guest it is April 10, 2021, 10:52:56 AM

Author Topic: Problem on Mach3 Index Input as Spindle Speed Indicator  (Read 4047 times)

0 Members and 1 Guest are viewing this topic.

Problem on Mach3 Index Input as Spindle Speed Indicator
« on: January 07, 2016, 08:45:40 PM »
I used the available hall sensor on my milling machine and configured Mach3 Demo Port Input Index to reflect its pulses.
I can see the actual Spindle Speed only if I press [Spindle CW F5] and the reading will stay visible and is being updated only if I RESET out of emergency mode.
I don't want to press [Spindle CW F5] only to see the actual Speed, and no Mach3 teaching video or instruction on the Web mentions that I have to press [Spindle CW F5].
My Mach3 installation can not control the spindle speed, it can not even turn the spindle on and off, so a "turn on Spindle" command is ignored anyway.

How can I configure Mach3 to display the spindle speed at least if out of emergency mode without pressing any button to 'turn on the motor' ?

The other question is: My hall sensor issues 4 pulses every 3 spindle rotations because it is mounted on the motor and has a belt drive pulley (no different gears).
How can I mathematically adjust the true spindle Speed using Mach3 ? Currently Mach3 shows 4000rpm if the true speed is 3000rpm.

Thanks.

Online BR549

*
  •  6,952 6,952
    • View Profile
Re: Problem on Mach3 Index Input as Spindle Speed Indicator
« Reply #1 on: January 07, 2016, 09:19:03 PM »
Later version of Mach3 will only show true spindle speed when the  M3 or M4 is active. It will NEVER be changed . So even if you do not have spindle control you must call M3/M4 to see true spindle speed. Just turn on teh spindle control and leave it constantly on. 

There is a setting called pulley ratio in the spindle setup. THAT is where you use math to adjust the differintial between actual RPM and indicated rpm.

(;-) TP
Re: Problem on Mach3 Index Input as Spindle Speed Indicator
« Reply #2 on: January 08, 2016, 07:06:00 AM »
Thank you for your answer.

So I added an M3 in Config:Global Config:Startup Modals:Init String and checked 'Use Init String on ALL Resets'.
Now the speed will appear on the screens at least if I'm out of emergency mode.
There is just an G80 in the init string, that now will be executed on more occasions. I hope that this will not interfere.

And I found Config:Spindle Pulleys... that does the Job niceley, I only wonder why Pulley 4 is selected by default.

One more question: If I use Ctrl-J Jog Controls (Arrow keys and PgUp/PgDn) to move manually, I realized, that it
moves in (slightley) different speeds if I use the buttons with oder without pressing the shift key simultanousley.
There are different speeds für Jog control in Config General Jog Increments in Cycle Mode, but they differ much
more (by 10, not just by 1:1.2 or so). Where can I modify/set_up the two speeds used using the arrow keys ?
(something like 'Use the speed in Feed Rate or Maximum Speed from Motor Config)

TIA

Re: Problem on Mach3 Index Input as Spindle Speed Indicator
« Reply #3 on: January 08, 2016, 08:35:25 AM »

One more question: If I use Ctrl-J Jog Controls (Arrow keys and PgUp/PgDn) to move manually, I realized, that it
moves in (slightley) different speeds if I use the buttons with oder without pressing the shift key simultanousley.
There are different speeds für Jog control in Config General Jog Increments in Cycle Mode, but they differ much
more (by 10, not just by 1:1.2 or so). Where can I modify/set_up the two speeds used using the arrow keys ?
(something like 'Use the speed in Feed Rate or Maximum Speed from Motor Config)

TIA



Hit the TAB key to bring up the pendant.
From the manual:

The jogging speed used with hotkeys in Continuous mode is set as a percentage of the rapid
traverse rate by the Slow Jog Percentage DRO. This can be set (in the range 0.1% to 100%)
by typing into the DRO. It can be nudged in 5% increments by the buttons or their hotkeys.
This Slow Jog Percentage can be overridden by depressing Shift with the hotkey(s). An
LED beside the Cont. LED indicates this full speed jogging is selected
Re: Problem on Mach3 Index Input as Spindle Speed Indicator
« Reply #4 on: January 08, 2016, 09:39:51 AM »
Thank you very much, this works fine, it was set to 95%.