Hello Guest it is May 22, 2019, 01:11:01 AM

Author Topic: SetParam Commands  (Read 1813 times)

0 Members and 1 Guest are viewing this topic.

SetParam Commands
« on: January 07, 2016, 10:03:41 AM »
This is for Mach3.

When Config settings are changed with the SetParam commands, are the changes updated dynamically or will the operator have to restart Mach3?
This is being done through input buttons on the Run screen.

Specifically, I have two customers who want to change the way Mach3 runs while the machine is in use.
Customer one wants to change the StepsPerAxis settings to adjust for changes in the thickness of a long rubber conveyor belt being fed through the system.
Customer two wants to change the Acceleration settings to dynamically adjust for the way the machine behaves while cutting on a waterjet system.

Thanks.

Offline ger21

*
  • *
  •  6,232 6,232
    • View Profile
    • The CNC Woodworker
Re: SetParam Commands
« Reply #1 on: January 07, 2016, 11:39:40 AM »
I know that you can change the homing speed parameter in a macro and it will change while the macro is running.

Not sure about the ones you want to change. I wouldn't try changing either while the machine is moving. I suspect that that's asking for trouble.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: SetParam Commands
« Reply #2 on: January 07, 2016, 11:51:36 AM »
Thanks for the fast reply.
To clarify, the changes would be made prior to running a job or while a job is in Pause mode.

Re: SetParam Commands
« Reply #3 on: January 07, 2016, 03:06:30 PM »
Re-reading your comments.
If you are saying that using the SetParam command "Axis"RefPer to change homing speeds results in an immediate change in Mach's operation, then I'm guessing I'm safe in assuming my answer should be "yes" - changes made with the SetParam Accleration command should update immediately to Mach's config settings and be used from that point forward.

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: SetParam Commands
« Reply #4 on: January 07, 2016, 03:13:07 PM »
You would not be safe in assumming that as Some CAN be updated and some are ONLY physically changed as mach3 shuts down. The actual parameter may not change untill Mach3 is reloaded and it loads up the XML file.

Also you have to account for teh size of teh Mach3 buffer some things are only effected after teh buffere is emptied some efffects are immediately on teh buffered data.

I would NOT assume anything but make actual tests to confirm it. I can however tell you that the Steps Per CAN be changed if Mach3 is in a non motion state such as NO gcode program loaded as I do just that in one feature I use. That is NOT to say it will work IF teh Gcdoe is actualy loaded and has been started then stopped.  It may NOT work if data is present in the buffer. Mach3 has MANY odd modes.

(;-) TP
« Last Edit: January 07, 2016, 03:18:46 PM by BR549 »
Re: SetParam Commands
« Reply #5 on: January 07, 2016, 03:36:51 PM »
Thanks for the reply.
You are right about testing - that will have to wait until I'm at the customer site next week.
I've run the macros on my local PC and they immediately update the Acceleration settings found in the Config / Motor Tuning tab.
If these SetParam based Acceleration changes operate the same as the changes made through the Config / Motor Tuning tab then I'm somewhat hopeful it should work.

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: SetParam Commands
« Reply #6 on: January 07, 2016, 03:40:01 PM »
Because Mach3 does NOT save a parameter change until Mach3 closes you may want to consider doing an XML file update from script after you script in a parameter change Otherwise what you update may not be what is actually saved on close .

Just a thought, (;-) TP
Re: SetParam Commands
« Reply #7 on: January 07, 2016, 03:50:10 PM »
Not saving the parameter change may turn out to be a good thing ;-)
The operator is expected to select an acceleration mode before running the job: Slow, Normal, or Turbo mode (basically, 0.05G, 0.1G, or 0.15G)
Any examples on doing the XML file update from script? That's a new one for me.