Hello Guest it is October 16, 2019, 09:09:43 PM

Author Topic: what computer for Mach3 - is "all in one" OK - is a parallel port mandatory?  (Read 6435 times)

0 Members and 1 Guest are viewing this topic.

I did email the company web site contact us address and got no response
I have tried to locate your e-mail and found one unanswered, this was it:

"I downloaded this driver as close to instructions as possible.  Following the instructions to page 3, it says start Mach3 and that box appears.

It don't.  Instead a box pops up saying Plugin DLL Defective Reload with a box to check that says okay.  Check that box and another box drops saying UC100 V2_146-Defective Plug Found.

How can I correct this.  Please make it simple as I am not a computer geek."

I guess this was yours, because I could not find any more unanswered e-mails in our system.
And I'm sorry for not answering, it seems we've missed to see this e-mail somehow.

However the answer to your issue is described in the UC100 manual, in the point 5. in the manual: http://cncdrive.com/MC/UC100%20datasheet/UC100%20users%20guide.pdf
I quite understand this.  I checked cables a number of times.  I went to plugins in Mach3 and deleted the driver and reinstalled this a number of times.  I think if you look at the date on that email you will see how long I have been playing with this.  This machine still isn't running. I am a old phart and just use this for relaxation but this hasn't been very relaxing,

However thanks for the reply

johnny
Yes, I understand, but you should really read the product manual before installing the device.
In the manual this particular type of issue is described with a printscreen of the error message and description of what to do.
You just have to install the prerequirement (the .NET framework 2.0 available for download on the UC100 page and also on Microsoft's website), otherwise Windows and therefor Mach3 can't run the plugin.

By the way, did you also ask the distributor shop who you bought the device from? They also did not reply? I'm curious.

And yes, the e-mail was really outdated and again sorry for not sending a reply, it sometimes happen unfortunately, because we receive a large number of e-mails and it can happen that we overlook one,
if this happens anytime in the future with anybody then please resend the e-mail. We reply within 24hours always (except on holidays and weekends), so if we don't answer in one day then there is an issue with receiving or with us missing to see the email and then please resend it.
I bought the device from amazon and they just say contact the manufacture
Dubbie  if you just read back you will find this


Re: what computer for Mach3 - is "all in one" OK - is a parallel port mandatory?

« Reply #8 on: March 03, 2017, 06:50:03 PM »
Reply with quote 


Craig,  I think I see the problem.  I needed a longer cable and with out even thinking, I go to Best Buy and buy a extension.  Thinking about it after reading  about  Model PMDX-411 SmartBOB-USB-DB25  where they advise no more than 15 feet but of a good quality cable.  I am betting the cable wasn't the proper gage cable so like men, all USB cables are not created equal

thanks
johny

As you see the blame is probably on me but support is always a good thing.  It's what you build a company one. First a good product and then product support
Yes, I see the cable might be wrong.
USB is limited to 5 meters cable lengths without amplification (non active USB cable), however the longer the cable is the higher the risk for noise problems will be,
mostly because the impedance of the ground wire will become higher and so the 2 ground points (PC and the external board) will be worse pinned together.
We recommend no more than 2meters of USB cable.

Anyways, that error message is sure not caused by a wrong USB cable, except if the cable was not working at all (cut cable) and so then the UC100 was never recognised by the computer, then the USB drivers could not be copied by Windows and that again causes a Mach3 defective plugin message.
Unfortunately Mach3 does not show details about why it can't run the plugin, it only shows this general message whatever problem there is with the plugin.

And I agree about the importance of customer support, I'm working for more then 10 years in customer support at CNCdrive.

And thank you for the info about the Amazon seller, I don't know yet who is selling at Amazon (I've never used Amazon services, because we are not in the USA and there is no Amazon in the EU), but will try to look it up and ask why they did not give support.