Hello Guest it is April 18, 2019, 07:19:49 AM

Author Topic: Mach4 Install on XP  (Read 5375 times)

0 Members and 1 Guest are viewing this topic.

Offline TDAY

*
  •  165 165
    • View Profile
    • Home CNC Stuff
Mach4 Install on XP
« on: December 10, 2015, 02:02:55 PM »
Trying to install Mach4 on a windows XP machine. After install, i try to launch Mach4 and get an error stating"Could Not Initialize the Core".

This is a 32bit windows Home XP that i just did a fresh install of OS today.
I havent been keeping up with the development of Mach4 (starting a new chapter) , so does Mach4 Ver 2 work on XP?
Thanks,
Troy
"I try to put forth the effort,before asking a dum question"
http://homecncstuff.elementfx.com

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Install on XP
« Reply #1 on: December 10, 2015, 05:58:03 PM »
try installing as admin it seems that is a problem at the moment with xp machines

Offline TDAY

*
  •  165 165
    • View Profile
    • Home CNC Stuff
Re: Mach4 Install on XP
« Reply #2 on: December 11, 2015, 07:07:27 AM »
User is set as admin. Also forgot to mention after closing the first error message, i get another stating 'There was a problem loading the screenset "" '.
« Last Edit: December 11, 2015, 07:09:53 AM by TDAY »
"I try to put forth the effort,before asking a dum question"
http://homecncstuff.elementfx.com

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Install on XP
« Reply #3 on: December 11, 2015, 04:23:54 PM »
do you start as admin

Offline TDAY

*
  •  165 165
    • View Profile
    • Home CNC Stuff
Re: Mach4 Install on XP
« Reply #4 on: December 11, 2015, 05:30:00 PM »
Yup.
"I try to put forth the effort,before asking a dum question"
http://homecncstuff.elementfx.com

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Mach4 Install on XP
« Reply #5 on: December 11, 2015, 05:34:00 PM »
can you put it on line and run update's you may have something missing, and yes window update still works for xp
Re: Mach4 Install on XP
« Reply #6 on: December 12, 2015, 11:29:03 AM »
do you have .net framework 3.5 and vcredist 2013 installed?

Offline TDAY

*
  •  165 165
    • View Profile
    • Home CNC Stuff
Re: Mach4 Install on XP
« Reply #7 on: December 12, 2015, 10:28:06 PM »
No, there is no .net nor vcredist 2013, unless Mach4 installed them. Ill check it out Monday and post my results.
Thanks,
Troy
"I try to put forth the effort,before asking a dum question"
http://homecncstuff.elementfx.com
Re: Mach4 Install on XP
« Reply #8 on: December 12, 2015, 10:51:52 PM »
I think those requirements only apply if your are trying to use the legacy Darwin parallel port driver.
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.
Re: Mach4 Install on XP
« Reply #9 on: December 12, 2015, 11:32:54 PM »
Mach4 uses the .net for sure........ not sure about the vcredist.