Hello Guest it is October 16, 2019, 06:32:48 PM

Author Topic: CSMIO-S Rigid Tap Cycle Runs on Program Load  (Read 1502 times)

0 Members and 1 Guest are viewing this topic.

CSMIO-S Rigid Tap Cycle Runs on Program Load
« on: November 28, 2015, 08:13:14 PM »
I have had this system for almost 18 months and have just now got it connected and powered up. I have been impressed so far but I have run into a couple of glitches
1st when I load a program with an M84, the machine runs the tap cycle as it regenerates the toolpath display. I have only loaded a single hole for testing so I don't know if it will do it for every threaded hole in the program, but my guess is it will.
2nd This is an old Bridgeport R2C3 machine which has a pneumatic brake to hold the spindle for tool changes. I set up a brain to turn off the brake when the spindle is on. This works normally, but not with the M84 cycle. This not a big deal as I can disable the brake manually.
How can I stop the M84 from cycling on regen?

Thanks
Cliff

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: CSMIO-S Rigid Tap Cycle Runs on Program Load
« Reply #1 on: November 29, 2015, 10:18:48 AM »
Put a tick in the box detailed in screenshot, it is on General Config page.
Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: CSMIO-S Rigid Tap Cycle Runs on Program Load
« Reply #2 on: November 29, 2015, 10:20:32 AM »
For your brake problem you could possibly make up a custom M Code to operate the brake and insert the custom M Code before the tapping cycle.

Hood
Re: CSMIO-S Rigid Tap Cycle Runs on Program Load
« Reply #3 on: November 29, 2015, 06:36:41 PM »
I had overlooked that. I knew it had to be something simple.

I have considered modifying the M84 code to turn on a bit that would disable the brake when running and turn it off at the end of the M84.
I was also going to look at the firmware changes to see if that was addressed.

Thanks again