Hello Guest it is May 10, 2021, 04:34:54 AM

Author Topic: No spindle rpm dro readout  (Read 1775 times)

0 Members and 1 Guest are viewing this topic.

No spindle rpm dro readout
« on: November 10, 2015, 09:49:45 AM »
I would really appreciate a little poke in the right direction on this.
The problem I am having is that I can not for the life of me figure out how to get Mach 4 to display my spindle rpm. I can see that mach is seeing the spindle index pulse on the diagnostics page but I have no idea how to get this information displayed on the 'current spindle rpm' dro. I'm sure its something really simple but I have no idea what I'm missing.
The setup I'm using is a pokeys 57cnc and I'm feeding a digital pulse to it from an arduino (this is a simple test setup so that I can see that mach is seeing the index pulse).
many thanks for looking and any advice you may have.

Re: No spindle rpm dro readout
« Reply #1 on: November 12, 2015, 03:11:16 PM »
I am pretty sure (but not positive) that this is a plug-in issue.  As far as I know the Mach4 core doesn't do anything with the index signal except record whether the index is high or low (1 or 0), and then tell all the plug-ins that the index input has changed state.  The device needs to calculate the actual spindle RPM and tell pass that along to the plug-in which in turn tells Mach4.  At higher RPMs, it becomes impractical if not downright impossible for the device to inform Mach4 of every transition on the index input.
Re: No spindle rpm dro readout
« Reply #2 on: November 16, 2015, 11:30:18 AM »
Thanks for the reply, looks like I will have to see if the pokeys thread can help sort this out.
It's becoming a bit frustrating looking at settings in the config that your think should do something but end up doing nothing!
Re: No spindle rpm dro readout
« Reply #3 on: November 21, 2015, 10:31:25 PM »
I am using Mach 4 and the SmartBOB-USB.  I see the spindle input toggling in both the Mach 4 diagnostic and the SmartBOB real time port display when I run the spindle but there is no RPM display in Mach.  I suspect I'm missing some set up step.  In Mach 4, I have the index pin configured as an input from SmartBOB.  Thanks for any advice.
Re: No spindle rpm dro readout
« Reply #4 on: November 21, 2015, 11:28:34 PM »