Hello Guest it is August 18, 2019, 05:33:35 AM

Author Topic: Mach3 + Geckos 201 + C11  (Read 3646 times)

0 Members and 1 Guest are viewing this topic.

Offline SiN

*
  •  3 3
    • View Profile
Mach3 + Geckos 201 + C11
« on: May 06, 2007, 11:25:36 PM »
Hi there,

Im trying to build a cnc router, mechanics are almost done, but electronics are the weak part of the project because of my complete lack of experience.
First of all im trying to control a single axis (X axis), power supply delivers 72v, the stepper wiring diagram as follows:

RED/-WHT = phase 1
YEL/-GRN =  phase 2

Communication with Arturo´s c11 is smooth, charge pump is fine, but when I send DIR and STEP signals, output leds flashes but theres no movement at all.

Any ideas?

Thanks in advance.



 



Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Mach3 + Geckos 201 + C11
« Reply #1 on: May 07, 2007, 01:25:23 AM »
Hi, SiN

Dose your stepper motor lock up with power on.

There should be low ohms reading from RED to WHT = phase 1 & connected to Gecko Phase A, B and YEL to GRN =  phase 2 to Gecko
Phase C, D.

Check your other stepper motors or disconnect motor to check.

Check pin 7 on your Gecko drive, If wire connected disconnect, Does the stepper lock up and work now (Disable Pin, Gnd to Disable Drine)

Gecko Pin 10, 5 Volts + from Arturo´s c11 board, Put a volt meter between pin 10 to pin 8, Should see 5 volts when stepping in one direction.

Let us know

Hope this Helps, Chip


Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Mach3 + Geckos 201 + C11
« Reply #2 on: May 07, 2007, 10:55:11 AM »
Also, do you have 5 volts supplied to the enable pin on the C11 board?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline SiN

*
  •  3 3
    • View Profile
Re: Mach3 + Geckos 201 + C11
« Reply #3 on: May 08, 2007, 01:25:48 AM »
Hi afn09556,

Pin 7 in gecko drive is not connected, I double checked and there are low ohms between red/white and yellow/green, Gecko's pin 10 is connected to c11's +5v and EN pin ( +5v next pin) is hard wired to 5v  power connection. Let me check 5 volts stepping voltage between pin 8 and 10  :)

Thanks Chip
                  SiN

Offline SiN

*
  •  3 3
    • View Profile
Re: Mach3 + Geckos 201 + C11
« Reply #4 on: May 08, 2007, 01:26:51 AM »
Brett,

Yes enable pin is supplied with 5v connection.

Thanks
           George