Hello Guest it is September 21, 2019, 06:01:20 AM

Author Topic: Limit switches ignored after re-install  (Read 2414 times)

0 Members and 1 Guest are viewing this topic.

Limit switches ignored after re-install
« on: October 29, 2015, 01:37:43 AM »
Mach3 was crashing when loading some G Code files.  Failed with the white screen of death and when restarted all machine and work coordinated has changed. Them fix was to cut and paste the required text into a loaded known working file, but I tired of that.

I carefully entered all settings into a spread sheet.  I then removed all traces of Mach3, and reloaded the program from scratch.  I entered all settings and add-ons (X-Box and my script for tool zeroing) and everything worked fin again. Once I remembered to turn on the charge pump output that is.

All limit switches operate and light up as they should on the diagnostic screen.  I have three switches, one each for X, Y and Z.  They are set to act as home and limits.  The X axis switch is at the numerically high end of the axis and the "Zero" setting value and the  direction to home are set accordingly.  All this worked just fine before the reinstall.  Also the tool zero script works fine as it did before.

Now however, on Ref All Home the Z axis tries to home and zero first, heads in the correct direction (Up) but ignores the switch and crashes.  Initiating the process with the Z axis down and operating the limit switch by hand while watching the diagnostic screen has the limit lighting up correctly, but the spindle continues to climb regardless until I hit RESET.

Search as I might, I have not found this problem  on this forum.  If it is here it's playing hide and seek from me very well.

The problem must lie in a setting somewhere.  But checking carefully and experimenting careful with all the possibly relevant settings I can see, I cannot get the function to work as it was before the reinstall. And, I cannot see anything different in the setting now from those I carefully recorded in the spread sheet and by screenshot.  It is probably something simple and is staring me in the face, but in two days I have not found it.  I cannot even set the machine coordinates from their current (odd and wrong) values.

Can anyone suggest a fix please?
Re: Limit switches ignored after re-install
« Reply #1 on: October 29, 2015, 07:35:35 AM »
Post the xml for the profile you're using.
Someone might see the problem there.
Russ
Re: Limit switches ignored after re-install
« Reply #2 on: October 29, 2015, 07:00:39 PM »
Thanks for the quick response.  I should have thought of posting the xml file.  It is attached to this post.

FYI the machine is a 6040 router, with Gecko 540 stepper driver unit.  The 6040 has limit switches on X,Y & Z, with the X axis switch at the "Max X" end of the gantry.

The PC is Win7 32 bit with an AMD 1.8GHz processor.  The connection to the Gecko is a UC-100 USP/DN25 converter.


Note all worked just fine until I reinstalled Mach3

Frustrating little sucker, this.
Re: Limit switches ignored after re-install
« Reply #3 on: October 30, 2015, 08:56:30 AM »
Do you see the switch activation on the UC100 I/O monitor ?
Re: Limit switches ignored after re-install
« Reply #4 on: October 30, 2015, 10:50:03 AM »
I had the same problem with the initial loading of Mach 3.  Tried for weeks trying to get the home switches to work.  Without having anything to lose I uninstalled Mach and reloaded it.  The home switches now work as they should.

Tom     
Tom
Re: Limit switches ignored after re-install
« Reply #5 on: October 31, 2015, 01:37:05 AM »
Yes, the limits (And probe) activate in the UC100 screen - and on the MACH3 diagnostics screen.  Just as they did before the reboot.

The issue is the DoButton(24) script command ignores the activated switches and screws ever onwards to impact at the physical end of travel (unless one emergency stops this process).

As a test I  removed the DoButton commands for the scripts, leaving the DoOEMButton lines, which I understand should zero the machine coordinates.  Nothing, Nada, Zilch effect. Put the machine by hand anywhere, activate the script and no change to the DROs.

My tool zero script detects the tool location, but then retreats and will not stop at its prescribe retract level or at the limit switch. AND although it detects the touch plate, it does not zero either Z DRO

Could it be that something is causing the program not to recognise or act on "Do" script commands?  If so what setting must change to reactivate them?

This is of course very frustrating, as the machine was working perfectly before I reinstalled Mach3 in an attempt to fix a different problem - fatal program crash on loading some text files. And, nothing was changed on the PC or the machine between the uninstall and the reinstall.

Since my last post I have reinstalled twice more.  I even downloaded a fresh copy of Mach3.  I even went through the registry bu hand and removed all traces of Mach3 before doing yet another reinstall.  I even system restored the PC to an earlier time and did yet another reinstall .I can do the config process in record time now, but to no avail.  Whatever mistake I am making, I keep making it.  I have even done the config to get the machine moving
and then changed one setting at a time to try and find a fix.  Nothing.


As a last resort I will write a script based on my too zeroing script in place of the standard one, but i doubt that can succeed because the part of that script that zeros the Z DRO does not appear to be working

Any other ideas anyone please?  At the moment I have a boat anchor for a dinghy, because I can't even figure out a way to set to zero  the machine coordinates at the stops by some handrauilc means.
Re: Limit switches ignored after re-install
« Reply #6 on: October 31, 2015, 09:16:44 AM »
Did you reload the plugins ?
Just a shot.
Russ
Re: Limit switches ignored after re-install
« Reply #7 on: October 31, 2015, 06:03:13 PM »
Good thought, but Yep.  Reloaded everything from scratch.

In the meantime I did find a way to zero the machine coordinates.  A bit clumsy, but at least I can use the machine.  I jogged the axes to the limit switches (Diagnostic lights ON) then backed each off in small steps until the lights went off.  Then disabled the switches in config. Finally I rah "Ref All Home", and that zero'd the machine coordinates. Then re-enabled the switches

I now have at least the protection of soft limits, but the limits still do not act as emergency stops, nor does the "Ref All Home" function work.

There is a wrong setting somewhere in config I am convinced.  Probably in the X++, X-- X Home etc settings or The Home/Soft Limit settings, but I can't see it. I did carefully record the original working settings, but either made a mistake then or after the re-install,  I have tried various combinations of these settings, but nothing I tries has yet worked.

It seems that my conclusion that Microsoft programs are the finikiest things on the planet may be wrong.  I have found another contender - Though I do not rule out the ghostly hand of said Microsoft in here somewhere.
Re: Limit switches ignored after re-install
« Reply #8 on: October 31, 2015, 06:31:44 PM »
Just noticed ... is there a reason that you do not want the Z to Auto Zero ?

Russ
Re: Limit switches ignored after re-install
« Reply #9 on: October 31, 2015, 07:21:51 PM »
No, not really necessary.  This is just how the initial limit switch settings were and that worked. And, the standard "Ref All Home" button does zero the Z axis, and does this first. I guess it is sort of convenient in that the "Ref All Home" button returns all axes to their machine zero positions.   If nothing else I guess this makes sure  careless bods like me can't forget to make sure Z is clear before the machine takes off to zero the other axes.


In practice of course, the Z axis is always set according to the tool fitted and the workpiece.  But at the moment even that script is not working properly.  I will disable the Z axis home and try that.  It may make the zero script work.

But I want to retain Z and all other axes switches as emergency stops.  But even that function seems not to be working at the moment

In desperation I am about to swap the current PC for another that has been driving my (now retired) 3040 machine with the current 4DizzieLizzie xml file.  I will post how that goes later.