Hello Guest it is May 14, 2021, 03:54:40 AM

Author Topic: Lua: Error occured while opening  (Read 1447 times)

0 Members and 1 Guest are viewing this topic.

Lua: Error occured while opening
« on: October 28, 2015, 08:23:21 AM »
When I open my Mach4 mill it gives me this message.  "Lua:  Error occured while opening filecannot open C:\Mach4Hobby\Profiles\Macros\mc.Lua.mcc: no such file director"
I looked in the 6 axis profile, it opens just fine with no error message.  I took the mc.Lua.mcc from the 6 axis profile and put it in the 4 axis directory (because it is missing) and it deleted it every time I tried opening it. 
Anybody no what this means?

-Chad
Chad Byrd
Re: Lua: Error occured while opening
« Reply #1 on: October 28, 2015, 09:45:45 AM »
Good chance that one of your m code files (mcs scripts in the macro folder are bad) and when Mach4 starts it tries to create the combined mcc file from all the scripts in the macro folder if one or more are bad it just cannot complete its task.

Either open each mcs script and see if they compile in the mcluaEditor on there own or move them all out and start putting them back in one at a time till you find the culprit.

That's one of the reasons for restarts in Mach4 to create or recreate the macro code (mcLua.mcc) for it to use. It checks to see if changes have been made and updates if needed, and why you can not share that file with other profiles.
Re: Lua: Error occured while opening
« Reply #2 on: October 28, 2015, 01:01:17 PM »
Ya-Nvr-No
Thanks for the help, I moved all the macros out of the folder and now it works!  Gonna figure out which one was the problem macro after lunch!

-Chad
Chad Byrd