Hello Guest it is August 17, 2019, 07:33:48 AM

Author Topic: Mach 3 launching media player as z axis movement  (Read 4333 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 launching media player as z axis movement
« on: May 06, 2007, 12:18:01 PM »
I was wondering if anyone here had mach 3 launch a media player or web browser during machine operations?
Mach 3 has been doing something to launch my media player and listing the media it is attempting to play as "z axis Movement" then my web browser pops up and mach 3 freezes while machining.
I emailed Art, but I wanted to see if anyone else had this problem?

ynneb

*
Re: Mach 3 launching media player as z axis movement
« Reply #1 on: May 06, 2007, 10:25:58 PM »
Thats an automatic feature to play music in order to drown out the cutting sound :)
Ok maybe its not. I have never heard this problem b4. Let us know what you find once Art responds to you.

Offline Scott

*
  •  139 139
    • View Profile
Re: Mach 3 launching media player as z axis movement
« Reply #2 on: May 07, 2007, 12:08:19 AM »
I haven't had it launch anything while using it, but ever since I started using it, when I close Mach3, a random program or file that is on my desktop will get zapped and either be opened or launched.   ???
Scott
Re: Mach 3 launching media player as z axis movement
« Reply #3 on: May 07, 2007, 09:03:43 AM »
You guys need to see if you have some junk on your computer that is making it do that... I can tell you that we are not opening any files other then the ones in the Mach3 directory and the Gocde file that you are looking to open..

As for the MediaPlayer... could you check and see that you have the wav files disabled under the general configs?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Mach 3 launching media player as z axis movement
« Reply #4 on: May 07, 2007, 11:31:04 AM »
Why it launched a media file titled z axis movement is still not understood, however I swapped my key board out because I thought metal chips were under the keys and it has not launched the media player since.

For some reason though while running gcode, the machine gets way off course. I created gcode to test for backlash by telling each axis to move back and fourth 25 times and then measure the amount of backlash from there, and my back lash is under control.
Yet when I run a 400 line gcode half way through the machine is off by 6mm in all axis. What could be causing this if my backlash is set properly.
I have been running the same gcode file for 6 months on a daily basis and never experienced this before. Could there be a unknown program stealing cpu or ram from mach 3 in windows xp?

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Mach 3 launching media player as z axis movement
« Reply #5 on: May 07, 2007, 12:21:46 PM »
I don't know about this.
Quote
Could there be a unknown program stealing cpu or ram from mach 3 in windows xp?
I haven't heard of it before. Are you sure your steps per are correct and that you are not loosing steps?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 launching media player as z axis movement
« Reply #6 on: May 07, 2007, 12:28:14 PM »
Like I said I have been haveing perfect results every time for 6 months. Suddenly all this started happening. So all the settings remain the same since the day I set up my configuration. Im running the machine right now with no stock in the vise just to see if the errors are consistent or if they are random.
I just ran the code and the only thing that was off at the end of the program run was the z axis. Im going to repeat the operation a few times and see if I can identify the problem.

After I get a set of results Ill let you know what is happening.