Author Topic: Tool fixed plate Z setting being very naughty. Help?  (Read 1000 times)

0 Members and 1 Guest are viewing this topic.

Offline boydage

  • Active Member
  • Posts: 35
    • View Profile
Tool fixed plate Z setting being very naughty. Help?
« on: October 28, 2015, 12:28:47 AM »
Hi. I have just reversed my settings to use the opposite end of my router table due to my workshop being too small. Running the 2010 screenset.

Everything is cool I have not set the homing switches to the other end yet but all works well with everything going in the correct directions etc.

I zeroed the Z on the mobile plate over the workpiece - nice. It retracted to 4mm.

I ran a program today. The spindle went to the new tool change position. Then it went to the new fixed plate position. Tool came down beautifully and touched down fine. Unfortunately as soon as it touched the second time it went from -45mm to -37mm and began its way back to the work piece with a new zero that was now 8mm too low. I was as fast as a cat and stopped it before it made me cry with a broken bit.

I have restarted the PC and also switched off my inverter to see if it was interfeering. No change - same result everytime.

I went to the tool change page and see out to the RH side there is a figure off the page that reads -36.85034??? Not sure what thats about but it is seemingly what the Z defaulted to once it touched off the fixed plate.

I have not been around my machine for a while but usually can suss things. This though has me stumped although for some reason 37mm seems familia?

Can anyone help? Mr Hood?

XML and poorly taken screen pic attached.
Regards
Boyd

Offline cncezee

  • Active Member
  • Posts: 13
    • View Profile
Re: Tool fixed plate Z setting being very naughty. Help?
« Reply #1 on: November 19, 2015, 03:39:00 PM »
 ???

I have a similar problem where the tool will touch the plate rise to a distance above the plate then rise again ending up about 4mm too high i am using latest code from Tweakie.CNC, any help is apreciated >:D