Hello Guest it is April 19, 2021, 01:52:46 AM

Author Topic: cursor keys not working  (Read 6560 times)

0 Members and 1 Guest are viewing this topic.

cursor keys not working
« on: March 07, 2006, 12:45:07 PM »
I posted this problem in the CNCZone forum and so far have not found a solution.   I'm using Mach2 and am not getting any manual movement of the axes with the cursor keys.  Everything else works fine; MDI, screen joystick, and program mode.   I've increased the pulse width and reloaded the latest version of Mach2 and the driver.  Ran the OCX test and came up blank.   Any clues?  Thanks in advance for any help you can give.

Steve
Re: cursor keys not working
« Reply #1 on: March 07, 2006, 01:38:27 PM »
Steve would you hold down shif and press and arrow key for me ? Will it move? also be sure that jog mode is on.
Thanks
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: cursor keys not working
« Reply #2 on: March 07, 2006, 04:59:07 PM »
Hi Brian,
  Yes, it works with shift and arrow keys!
Re: cursor keys not working
« Reply #3 on: March 07, 2006, 06:38:55 PM »
I think you are in Inc Jog mode :) OR you have the Slow jog rate set VERY low...

Hope that helps
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: cursor keys not working
« Reply #4 on: March 08, 2006, 08:13:42 AM »
It is in IJ incremental and the jog rate is .1000.  I switched IJ mode to absolute in the config/setting window but still no change.   Is there another setting that I'm missing?

Steve

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: cursor keys not working
« Reply #5 on: March 08, 2006, 09:43:33 AM »
Not IJ incremental, incremental JOG mode. What Brian's saying is that there are different jog modes that you need to check to see which one you're currently in, and you may have the jogging modes turned off.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: cursor keys not working
« Reply #6 on: March 08, 2006, 12:41:46 PM »
Hi Gerry,
Jog mode is on.  Incremental jog works OK but continuous jog does not work unless I use the shift key with the arrow keys.   Is there a setting that needs to be changed?  Perhaps the keyboard map has somehow been altered.

Steve

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: cursor keys not working
« Reply #7 on: March 08, 2006, 01:29:29 PM »
As brian mentioned, try increasing the slow jog rate.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: cursor keys not working
« Reply #8 on: March 08, 2006, 02:46:37 PM »
Oh...I mistook slow jog rate for jog step increment.   Still don't know how that got changed but it's all better now.  Thanks to you both and have a happy St Patty's Day.... Slainte!

Steve