Hello Guest it is October 15, 2019, 03:44:27 PM

Author Topic: It just stopped working !  (Read 5220 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  7,947 7,947
  • Super Kitty
    • View Profile
    • Tweakie.CNC
It just stopped working !
« on: October 21, 2015, 07:50:32 AM »
 Nothing to do with CNC but my Yamaha MagicStomp just stopped working, the display backlight would illuminate but that was it and as this pedal is no longer in production it was either repair it or bin it. Perhaps a compelling argument for a repair is that these pedals are now selling second-hand (or should I say second-foot) for around double the price they cost when they were new !

 It transpires that in the start-up sequence the control microprocessor writes to the display and then waits for a reply. Testing the display in this manner is just fine for Medical & Aeronautical equipment but hardly necessary for an effects pedal - after all, if there is a problem with the display the software just hangs forever - still, that’s the way it is.

 The actual display is a 16 char 2 line - cheap and readily available – tricky to replace (soldering skills required) but not rocket science. I chose to replace the original yellow / black with a high contrast blue / white display and for an hour or so quite delicate work I have an old friend back.

Tweakie.
« Last Edit: November 07, 2015, 06:26:08 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Tweakie.CNC

*
  • *
  •  7,947 7,947
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: It just stopped working !
« Reply #1 on: November 07, 2015, 06:22:48 AM »
This is what happens when I get cocky...

Q - Can you repair my Magicstomp Acoustic please.
A - Yes, easy peasy - just drop it round.

Well it was the same problem - failed display - so I removed the old display and soldered in another (I had a spare Blue one and everybody likes the blue) go to test it and guess what duff column of pixels in the replacement display.  :'(

Easy enough to de-solder and fit another but it highlights the reject rate we must accept when buying cheap from China. These 16 character 2 line displays cost GBP 1.20 including postage from China so what can we expect.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Chaoticone

*
  • *
  •  5,606 5,606
  • Precision Chaos
    • View Profile
Re: It just stopped working !
« Reply #2 on: November 07, 2015, 12:15:50 PM »
Quote
Easy enough to de-solder and fit another but it highlights the reject rate we must accept when buying cheap from China.

So true Tweakie. Some expect the cheap bits to require extra effort. Its the ones that buy cheap and expect to get quality that simply do not realize what it is they are getting into.

Good job Tweakie! If I had to give you a forum name it would be universal soldier. You battle lots of different issues and fix them all. :)

Or maybe Mr.Talent.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Tweakie.CNC

*
  • *
  •  7,947 7,947
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: It just stopped working !
« Reply #3 on: November 08, 2015, 06:25:56 AM »
Thanks Brett, you are too kind my friend.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: It just stopped working !
« Reply #4 on: November 08, 2015, 03:41:04 PM »
His real name is TweakieMan, he is one of the Super Heros.  ;D

(;-) TP

Offline Tweakie.CNC

*
  • *
  •  7,947 7,947
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: It just stopped working !
« Reply #5 on: November 09, 2015, 01:47:03 AM »
 :)

I don’t know if it’s just co-incidence or if it is some other influence but similar things never seem to happen in the singular they always happen in multiples (perhaps 3 or 5).

I have just noticed that the display on my Alesis Quadraverb is now getting very dim and difficult to read. Looks like another display replacement is necessary – this time I think it is just a plug-in (without any soldering required).

Tweakie.
« Last Edit: November 09, 2015, 05:55:24 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Tweakie.CNC

*
  • *
  •  7,947 7,947
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: It just stopped working !
« Reply #6 on: December 28, 2015, 07:44:09 AM »
To complete the story of the Magicstomp Acoustic the second Chinese LCD display to be fitted works perfectly  ;)  and just for fun I have programmed the unit with, as well as the 99 acoustic preset patches, 99 of the simulated Meazzi and Binson tape echo's of the 60's.

Tweakie.

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Chaoticone

*
  • *
  •  5,606 5,606
  • Precision Chaos
    • View Profile
Re: It just stopped working !
« Reply #7 on: December 28, 2015, 10:12:38 AM »
Awesome Tweakie!

Just what I tell folks all the time. Tweakie makes everything better.  :)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!