Hello Guest it is April 03, 2020, 02:19:44 AM

Author Topic: problem with Z axis  (Read 1963 times)

0 Members and 1 Guest are viewing this topic.

problem with Z axis
« on: October 11, 2015, 03:29:57 PM »
Hi I'm new here and I'm trying to learn how to use my GreenBull 5x10 CNC machine. I speach french (Quebec, Canada), I'll try to do my best in english. I saw a lot of Youtube videos, ans I'm almost ready to cut. But I have problems with the Z axis. I set the motor tuning (usually it gives me 6400) but almost each time I try to run a G-code, when the tool go up, no problem, but when it goes down, it's always too much. So it goes 1/4" up, go down 1/2", goes up 1/4", goes down 1/2"... not exactly that, but it gives an idea...

When the table was assembled, X and Y axis were perfect, but the Z axis was working the reverse way, so when nI was pushing the Z+ button, it was going down. I took the motor and turned it upside down. Someone can help me please? I have a big contract soon and I need it!
« Last Edit: October 11, 2015, 03:32:31 PM by rayco »
Re: problem with Z axis
« Reply #1 on: October 11, 2015, 06:38:09 PM »
Can you provide a copy of your XML file

Go to: C:\mach3 >>> sort by filetype, scroll down the bottom and find the "*.XML" file with your profile name associated with it copy and paste it here to have a look at.

I do not understand how you "... took the motor and turned it upside down...."    >>>> All you had to do was change the "DIR" pin setting for your Z-Axis within your Mach3 >>> Config >>> Pins and ports >>> Motor Outputs >>>> and flip / switch the "Dir LowActive"  setting / state the opposite direction and the motor direction would have reversed.

Rob

Google translate:>>
Pouvez-vous fournir une copie de votre fichier XML

Aller à: C : \ Mach3 >>> trier par type de fichier , faites défiler le bas et trouver le " * .xml " fichier avec votre nom de profil associé à copier et le coller ici pour jeter un oeil à .

Je ne comprends pas comment vous " ... pris le moteur et tourné à l'envers .... " >>>> Tout ce que vous aviez à faire était de changer la "DIR" réglage de la broche pour votre Z - Axis au sein de votre Mach3 >> > Config >>> Pins et ports >>> Sorties moteur >>>> et Flip / changer le réglage "Dir LowActive " / état ​​la direction opposée et la direction du moteur aurait inversé .
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: problem with Z axis
« Reply #2 on: October 12, 2015, 01:10:22 AM »
Yeah that's the better idea to understand the problem because i'm also following this thread
Re: problem with Z axis
« Reply #3 on: October 12, 2015, 01:57:58 AM »
.... You may need to either zip up the XML file or rename it to something else like "*.txt" in order to post the file.

Do you know what threaded rod / leadscrew pitch you have installed, 8mm, 10mm?


.... Vous devrez peut-être soit zip le fichier XML ou le renommer à autre chose comme " * .txt " afin d'afficher le fichier.
Savez-vous ce que la tige filetée / pas de vis que vous avez installé , 8mm , 10mm ?

Rob
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: problem with Z axis
« Reply #4 on: October 12, 2015, 10:57:08 AM »
Alot of times changing the DIR LowActive setting can have an impact on stepper drives.  The best way I have found is going into the CONFIG>HOMING/LIMITS and changing the the setting in the reversed column for the axis that is going the wrong direction.  This screen is also where you reverse the direction of the homing "HOME NEG' column if you have home switches setup and it is homing in the wrong direction.

I think that your problem may be in your gcode.  it sounds to me like the Z up move is a clearance move.  The z down move is a cut move.  below the Z zero point.  If you are running G code, can you copy and paste a section of it that has the Z moves? 
Re: problem with Z axis
« Reply #5 on: October 15, 2015, 05:03:41 PM »
Ok Robertspark, the reason is it is because I don't know anything about CNC, I'm learning from scratch and from videos I find on Youtube... thanks for the trick "Config >>> Pins and ports >>> Motor Outputs >>>> and flip / switch the "Dir LowActive"  setting / state the opposite direction" it was so simple! It works like magic
Re: problem with Z axis
« Reply #6 on: October 15, 2015, 05:05:35 PM »
Now another question: how do I put the tickness of the material I put on the table to be cut? If I want to cut 3/16" polycarbonate... how and where? I learned the rest, how to make G-code, it's working very well....
Re: problem with Z axis
« Reply #7 on: October 15, 2015, 05:21:52 PM »
well... I don't "make" g-code.... I use CAM software .... there are a few about, but my chosen one is http://www.sheetcam.com/

the thickness of the material to to be cut is not entered anywhere except in the CAM software...

It all depends upon what you want to cut and what you are going to cut it with (feedrate and cutter speed)...

I use a plasma cutter so cutter speed is not really of a concern to me... but feedrate is (the speed the plasma cutter moves)..... the cutter speed is the RPM (revolutions per miniute) of the cutter.

Also the depth of cut comes into play.

I would suggest having a look at a number of youtube videos as its a long process but by far the easiest (and cheapest) software for me was sheetcam.
https://www.youtube.com/watch?v=hk7WNZ-erY8


Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: problem with Z axis
« Reply #8 on: October 15, 2015, 05:53:19 PM »
I work with Lazycam, I have my feedrate and cutter speed, that's ok.
Re: problem with Z axis
« Reply #9 on: October 15, 2015, 05:57:15 PM »
Sorry, can't help, you may need to post in the LazyCam section and see if someone will help there.

Rob
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”