Hello Guest it is May 21, 2019, 11:21:40 PM

Author Topic: Setting Acceleration and deacceleration time values in mach3  (Read 1664 times)

0 Members and 1 Guest are viewing this topic.

Setting Acceleration and deacceleration time values in mach3
« on: October 08, 2015, 02:33:41 AM »
Dear All,

       I need to set Acceleration and deacceleration time for linear interpolation in mach3. I have tried with Mach3>config>Motor Tuning> Acceleration , but no effects on the vector acceleration and deacceleration in linear interpolation. can anyone tell me how to set the accel. and deaccel. time values in mach3 ?

Offline beefy

*
  •  138 138
    • View Profile
Re: Setting Acceleration and deacceleration time values in mach3
« Reply #1 on: October 08, 2015, 03:07:15 PM »
It's done in the Motor Tuning section BUT if you have an XY plane (X & Y motors) and let's say X is set to 4 metres/min and Y is set to 8 metres/min. The limiting motor is X. If your linear interpolation required more than 4 from X, it wouldn't happen. Both motors have to have a high enough max speed to allow your desired interpolation speed.

Could that be what's causing your problem.

Keith.
Re: Setting Acceleration and deacceleration time values in mach3
« Reply #2 on: October 13, 2015, 06:51:13 AM »
I have changed the Accel. Values in the Config>Motor Tuning Section and now it works fine. For Linear interpolation, With low Accel Value motors are sre starting/stopin slowly and with high Accel Values Starting/Stoping rapidly. For the circular interpolation (G02 & G03) also I have tried the same , but high and low Accel values are not giving any difference in the motion.