Hello Guest it is September 27, 2020, 06:23:39 AM

Author Topic: Missing steps on direction change  (Read 7724 times)

0 Members and 1 Guest are viewing this topic.

Re: Missing steps on direction change
« Reply #10 on: October 16, 2015, 05:35:14 AM »
Basically it rules out electronic/mechanical problems

While I agree with "mechanical" I believe "electronic" is in no way "ruled out".  By changing to different electronics you've altered the the line impedance so the pulse shapes will be different.  You've likely changed the noise situation by having the wires not running in the same exact positions and near their same neighbors.  And likely, though I'm not sure, the actual pulses may well be different in length - which can change everything.  The driver can be flat-out missing pulses.

All this stuff has to be fairly deterministic so what is asked for you get every day.  What that means is problems can also end up being very deterministic - given all the same preambles(moves) the same errors will likely occur in the same places.

I suspect your MACH3 pulse periods are ragged-edge too short so certain pulse-trains set the drive up to reliably (deterministically) miss pulses - repeatedly.  Try increasing your pulse periods and see what happens.

By the way I loved your test setup.  I'm going to try that.
Re: Missing steps on direction change
« Reply #11 on: October 16, 2015, 09:17:10 PM »
I had a very similar problem. It took me quite a while to figure out that a motor coupling was loose and would slip in one direction only!  Might want to check that.

Offline wl888

  •  10 10
    • View Profile
Re: A posible Solution to Missing steps under Mach3
« Reply #12 on: November 07, 2015, 10:59:12 PM »
Solution-one option
Have been having lost step problem for ages also, tried everything i could find on the forums, nothing made a difference. >:(
I have a reasonably modern computer running Windows7 (was XP), Mach3 066.
The steps i followed to test this solution were as follows:
Ran a stepper under Mach3 with my std configuration, could actually feel the steps missing every now and then, this was under full step down to 1/32.
Made the system changes (see below)
Without changing Mach3 at all, re-ran the test, this time there was NO indication of missing steps
What I did : Under Windows Control Panel...System and Security...Power Options..Balanced goto Change plan settings...change BOTH boxes to NEVER.
I later fine tuned the Motor Setting in Mach3 on Step to 10us and Direction pulse to 5 us, lower settings also worked but these were optimum for me.
NB: this was a bench test not on a working machine, as mine is down at the minute, but indications are good that this is a solution for me.
Why does this work...not a clue..but it seams to. ???
I have not seen this on any of the other forums.
Hope this helps and if anyone tries this and it proves workable please let me know.
Doug  :)
Re: Missing steps on direction change
« Reply #13 on: February 19, 2020, 02:56:49 PM »
Mach 3 both x and y axis shift zero during job . I did a test back and forth 1 inches hundred time and at the end goto zero command is send and it moves 2 mm away from zero