Hello Guest it is July 17, 2019, 11:14:58 PM

Author Topic: unable to activate Mach3 after download: remains in demo  (Read 2222 times)

0 Members and 1 Guest are viewing this topic.

unable to activate Mach3 after download: remains in demo
« on: September 15, 2015, 05:56:29 PM »
Hi.
First, I have Mach3 running on another machine I use for a CNC router. It works fine. I just bought a 'new/old' pc running XP and it is a 32 bit machine. I have downloaded Mach3 and it successfully loads, including the parallel driver. I have a product license in a zipped file; 6667 I think is what it's labeled. I have dropped the file into the Mach3 folder on my C: drive.

I fully expected Mach3, when opened, to say 'Licenced to....' but it still displays 'demo'. I have been through several iterations of loading and reloading Mach3, booting/restarting, including deleting the entire folder on the C: drive and starting from scratch- same thing...Says 'demo' and also says 'demo' in the HELP screen. I took the license from two different sources: 1) the working PC and 2) the original email I recived when I purchased it........Neither works on the 'New/Old' PC.

Am I doing something wrong here?

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: unable to activate Mach3 after download: remains in demo
« Reply #1 on: September 15, 2015, 06:14:18 PM »
Are you using two different versions of Mach3?
Where'd you get the license from?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: unable to activate Mach3 after download: remains in demo
« Reply #2 on: September 15, 2015, 06:55:43 PM »
I got the license from New Fangled/artsoft. I'll have to check the versions but here's the funny thing- The original version was dowloaded just about a year ago. That's an XP machine, we'll call XP-working.

I had another machine, one running Win7 and a 64bit machine. We'll call that 7-64

I downloaded the same version of Mach3(yesterday) that I just loaded to the (newly purchased/old)XP machine, we'll call XP-Broken, and it did indeed said 'licensed to john doe' on the 7-64 bit machine.....after I dropped the zipped license folder into the Mach3 folder. It does not on XP-Broken.

So they both had the same version downloaded from Artsoft yesterday, but one recognizes the license (7-64) and one does not (XP-Broken). That machine, the 7-64 bit, I'm told, will not load the parallel driver (and in fact it did not install it), and so I purchased this machine today: XP-Broken, 32 bit, in the hopes to get it all installed on a compatible machine......

As an anecdotal observation, I do see that the zip folder, containing the license, has an icon assigned in XP that's a generic; in other words it appears not to be associated with an unzip tool in Windows XP.....it does unzip however if I double click on it. Anyway, it's something I'll look at.

Bob T.
« Last Edit: September 15, 2015, 06:59:16 PM by injunear »

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: unable to activate Mach3 after download: remains in demo
« Reply #3 on: September 15, 2015, 07:16:42 PM »
contact license@machsupport.com
They should be able to help you.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: unable to activate Mach3 after download: remains in demo
« Reply #4 on: September 15, 2015, 11:17:55 PM »
Well, thanks but given I'm not trying to debug Mach3 but only trying to integrate my Laser I don't want to get diverted on a boondoggle that's simply going to eat my time.....The one thing I counted on was the MACH3 software cooperating..... ;D  It hasn't. It could be the PC, likely it is, but like I said- no time....

So anyway, in the interest of going forward and staying on track with my project, I tried something that did work. I copied the entire folder from XP-working PC and installed it in the C: root of XP- Broken PC (after renaming the old folder).

Given the motors go whirrrrr....and I can jog, I have to assume I'm good to go. It also says 'licensed to John Doe' as it should. I just need to edit this profile (my Router) and make it a profile for my Laser machine.

I'll eventually go back and deal with the Mach3 issue later....ONLY IN MY WORLD, IT SEEMS...TWO DESKTOPS AND THREE DAYS LATER I CAN FINALLY MOVE FORWARD. ::)

Thanks,
Bob T.
« Last Edit: September 15, 2015, 11:21:43 PM by injunear »

Offline RonC

*
  •  32 32
    • View Profile
Re: unable to activate Mach3 after download: remains in demo
« Reply #5 on: September 16, 2015, 07:28:52 AM »
Are you putting the zipped folder into Mach? You should unzip the folder and just put the Lic.dat file into your Mach folder.
Re: unable to activate Mach3 after download: remains in demo
« Reply #6 on: September 16, 2015, 11:17:17 AM »
RonC- I have tried it both ways, but when I've tried the unzipped way, it produces a folder, and I have placed the folder into the MACH3 root directory. I never tried placing the just the Lic.dat file there. But, alas, this works on other PC's so there's something going on with this XP-Broken......In fact, the file's not unzipped in the current working copy I placed on the XP-Broken pc.

I can switch back to the defective install simply by renaming the entire folder so I'll try it later.....

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: unable to activate Mach3 after download: remains in demo
« Reply #7 on: September 16, 2015, 11:35:06 AM »
That's your problem. Put the Lic.dat file in the \Mach3 folder, not in another folder.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: unable to activate Mach3 after download: remains in demo
« Reply #8 on: September 16, 2015, 12:44:05 PM »
Yes, that was the problem....On the two PC's that worked, the file self-extracted from the zip folder. The XP-Broken does not self extract for some reason. I did however unzip it manually and then opened the folder it was enclosed in (mach3) and placed the .dat file directly into Mach3 root. It works now......

Thanks all...

Bob T.