Hello Guest it is August 20, 2019, 10:36:54 AM

Author Topic: Ref All Home  (Read 1347 times)

0 Members and 1 Guest are viewing this topic.

Ref All Home
« on: September 14, 2015, 11:47:07 AM »
Started my CNC machine after a month idle time, tried to Ref All Home. The Z & Y axis move fine. The X axis moves but the slave axis A does not. If I jog the X axis both X & A move. During home the X axis will move until the gantry angle is such that it stalls and chatters. This did work previously, I tried older versions of my configuration (xml files) with no success. Looking for some direction as to what might have changed.

Hardware Gecko G540 4 Axis stepper
Software Mach3 vr3.043.066, ESS v10r2d1d
Re: Ref All Home
« Reply #1 on: September 19, 2015, 08:26:45 PM »
It's been along time since I've looked at that, but when I set my machine up there was something on homing sequence that I had to do. Everything worked fine but it seems like I had to make some tweaks on the homing sequence. Sorry I couldn't give more
help or direction.
Re: Ref All Home
« Reply #2 on: September 19, 2015, 10:24:30 PM »
I configured the Slave A = X last winter when I setup the machine, it has worked perfectly since. After a month of idle time it just stopped working. I'm going to reload mach3 to see if it resolves the problem. If I power down the cnc machine before exiting mach3 it hangs (no response), I've done this a couple times and suspect it may have corrupted something!

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Ref All Home
« Reply #3 on: September 20, 2015, 03:12:40 AM »
I think you need to edit the ref-all button code and change the X ref to refcombination( 10 ) possibly. Thats what my machine uses and i have X slaved with A.

I have a home/limit switch on X and A
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives