Hello Guest it is December 16, 2019, 06:11:14 AM

Author Topic: Mach4 and HiCON -  (Read 2487 times)

0 Members and 1 Guest are viewing this topic.

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Mach4 and HiCON -
« on: August 31, 2015, 04:23:17 AM »

Warnings and errors as shown in attached snip.

What do these mean?

Should they be corrected?
« Last Edit: September 28, 2015, 04:59:18 PM by Vital System Support »
Re: Mach4 and HiCON -
« Reply #1 on: August 31, 2015, 12:03:49 PM »
Hello,

The first message indicates a slow-down of the data exchange rate between Mach4 and the motion controller which usually appears when Mach4 is just started up, or if a connection is first established by the controller, in which case is pretty normal. However, if it occurs during normal operations, it could indicate that there is an issue with the network connection.

The 2nd message is a result of the plugin waiting for motion buffer to be consumed by the controller, and not any data loss over the network. This is evident with the "Motor Set Still..." message for motor1 which can only be triggered if the controller has successfully processed all the necessary motion. In the plugin, there are sequence number checks to ensure that each and every move vector is processed by the controller and no packet is dropped.

In the debug window, instead of calling it "SET STILL DELAYED.." it should be something like "WAITING FOR MOTION COMPLETION..."  Will try to update it in the next release.

So the answer to your question is that these conditions that are being 'reported' do not need to be corrected :)

Regards
Vital Support

« Last Edit: August 31, 2015, 08:40:46 PM by Vital System Support »