Hello Guest it is December 13, 2019, 10:09:09 PM

Author Topic: Programme dwelling  (Read 1648 times)

0 Members and 1 Guest are viewing this topic.

Programme dwelling
« on: August 27, 2015, 04:20:21 PM »
I am having a problem with the Mach 3 programme, I start the programme and it runs for about 2 minutes and then the programme dwells. I am not able to continue any further into the cutting programme. Has anyone got any ideas on why this is happening, it's driving me mad.

Offline Tweakie.CNC

*
  • *
  •  8,022 8,022
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Programme dwelling
« Reply #1 on: August 28, 2015, 10:33:36 AM »
Can you describe what is happening in a little more detail please.

Is Mach3 code execution just pausing or is the program locking-up ??
Has E-Stop been triggered ??
Is there any message in the Status window ??
Do you have a license or are you running in Demo mode ??

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Programme dwelling
« Reply #2 on: August 28, 2015, 07:43:07 PM »
I already have one machine controlled by the Mach3 software which runs without any problem, this is run throuh a HP desktop PC.
I used the same compressed file to load programme into a Dell desktop PC, Mach3 programme loaded fine.

I duplicated all the settings from the one that is running fine, double and triple checked.

I created a programme using artcam software, created the G-code file. Loaded that file into Mach3. Clicked on the start button and the machine responds to the commands, until it gets to line 997 of the G-code file then the Dwell light flashes on the Mach 3 screen.

No message comes up it the message box at the bottom of screen.

Swapped over to the HP pc and the same G-code runs fine.

Hope there is enough detail for you, and many many thanks for your reply.
Jona

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Programme dwelling
« Reply #3 on: August 28, 2015, 08:14:36 PM »
SOUND like there is a dwell there and 1 PC is set for seconds dwell and the other is set for Microseconds dwell  . The MS dwell yo may not notice but teh seconds you would.

Just a thought, (;-) TP
Re: Programme dwelling
« Reply #4 on: August 29, 2015, 05:44:53 AM »
ThanksTP this is what I thought I have been through all the settings on both pc's and the check box for dwell has not been checked on either. so I am confused as to why the cutting programme is dwelling.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Programme dwelling
« Reply #5 on: August 29, 2015, 11:15:38 AM »
LOok at teh Gcode at that point do you see a G4 Pxx somewhere around there.  IF the dwell like is coming on it is coming from somewhere. Post a section of the code at that point say 20 lines before the problem to see IF the problem is in Gcode.

(;-) TP
Re: Programme dwelling
« Reply #6 on: September 12, 2015, 03:36:09 AM »
Sorry I have been offline for a while, cannot find anything wrong with the programme. Have linked up to another PC and the machine runs through the programme without a problem. I am still a little puzzled as to why I have the problem with the other PC, Is it the PC?
Thanks for your thoughts on the problem much appreciated.

Offline rcaffin

*
  •  1,007 1,007
    • View Profile
Re: Programme dwelling
« Reply #7 on: September 12, 2015, 06:08:38 AM »
Is it licenced? Are you running into the 500 line limit?

Cheers
Roger