Hello Guest it is December 12, 2019, 03:39:24 AM

Author Topic: HiCON general info on Stepper testing  (Read 1930 times)

0 Members and 1 Guest are viewing this topic.

Offline Mauri

*
  •  306 306
    • View Profile
HiCON general info on Stepper testing
« on: August 22, 2015, 07:32:21 PM »
Hi,
We have made a Controller using a HiCON card with the same button controls as the Mach4 and all function correctly
We are at the final test stage of testing and are awaiting fixes on two main issues with Mach4/HiCON.
1) CV to be updated on Mach4 (currently being worked on)
2) MPG to correctly increment with .01mm and .001m increment settings (not sure if Mach V2 2651 has fixed this issue?)

Here are some handy tips when using the HiCON Plugin for testing Steppers (refer to the Motor3 TAB on the HiCON Plugin).

When do we Save Config?
- The config is saved when you hit OK or APPLY on the plugin window. But it is only written on the hard disk when Mach4 closes.

Where does it save too?
- The config is saved in your Mach4 profile ini file.

When do we Update HiCON?
- I would recommend using the “APPLY” button instead.

Do the settings as shown on the HiCON Config Pane get saved to the HiCON card?
- Yes, but these are lost when the HiCON loses power.

When do we Export Data?
- Export data is meant to write the graph data to a file. Not sure this works in Mach4 yet.

Does this data go to a file for later viewing?
- Yes, it’s supposed to.

How do I turn on the HiCON debug window?
Go to the HiCON plugin System Tab and click the "Enable Debug Windows", this will display a continuous listing of the commands sent to the HiCON card.


Why does this appear in the HiCON debug log display?
[15:14:10] ###WARNING: Reduced Timer Socket receive poll rate detected (42 pkts/sec) 1.6831e+007
[15:14:10] ###WARNING: Reduced Timer Socket transmit poll rate detected (3 pkts/sec) 1.6831e+007

This message is displayed in the black debug window if the connection appears to be lagging (e.g. when the communication rate drops below a threshold of 80%). This is normally seen on Mach4 startup, or during a disconnect. If this message shows intermittently, then it could mean that Mach4 itself is lagging (probably because your CPU is stressed), or if your network connection is slow or unstable.

What settings should I have on Input Gain and Motion Threshhold Counts?
The best setting for the Input Gain is 1 so that the commanded position will have a 1:1 ratio with the actual executed motion. For Motion Threshold Counts, our base setting is 4 so we can account for the small jitters that might occur on your motor when it’s still, and 4 counts is our error mark for judging if the generated motion is off-target or not. But, this value can change depending on the tightness of your drive tuning.
But if you really what “the best” settings, then please give the Mach4 integration manual a good read so you can judge for yourself if these settings are optimal for your machine. Because almost all machines have their own differences “the best” settings are completely dependent on your hardware. There is no “one-size-fits-all” group of settings.  The default Mach4 profile was provided as a starting point for users to get motion going right off the bat, but it will still require further configuration on all machines.

An example of Stepper Motor testing using HiCON Driver (Pic)

In our testing we had the motor was very close to our Controller and had an unshielded cable, the HiCON motor screen provided a good way to test for spikes.
Below (Pic) is an example of what you will see (this appeared in our example every 5/6 times after pressing the execute button quickly). By just placing a ferrite over the cable (for example), the issues disappears.

Regards,
Mauri.

« Last Edit: September 28, 2015, 05:00:47 PM by Vital System Support »