Hello Guest it is October 01, 2023, 03:43:37 PM

Author Topic: Smoothstepper ESS new setup failing to connect  (Read 7089 times)

0 Members and 1 Guest are viewing this topic.

Smoothstepper ESS new setup failing to connect
« on: August 14, 2015, 01:30:27 PM »
I got a smoothstepper ESS to connect my tower running 64 bit windows 8.1 and G540 driver box.

I followed the instructions in the manual on Warp9's website as well as those instructions for setting up the IP address. 

I have checked and rechecked that everything is correct, in cmd that the IP was updated, that it could ping the board. 

When I open mach 3 to select the board as the controller for mach 3 to talk to, I select the ESS, click no to the prompt that says CTftp:WakeUpClient Board does not reply, and am able to input the board IP of but when I press enter the exact same message appears and it loops without ever connecting to the board. 

After trying this, going over everything.  Installing Mach 3.x.62 instead of .66 and trying again. Nothing worked.

I then downloaded the configurator and restarted the ESS in BootP.  Any attempt to make any configuration with the configurator results in the program freezing for a short while followed by two pop up notifications: "is not working. Retry or Quit Plugin (cancel)?"  and  "FT_Write - Server is not running"

I also tried turning the firewall off entirely without result and downloaded and tried Wireshark which indicates the computer is trying to communicate with the board.  Status LEDs on the board all read normal including the ethernet LED flashing showing there is some kind of data transfer. 

The only thread I have read that had a similar issue was related to a VPN program encrypting the Ethernet signal but this is a new PC with nothing that I can find in task manager that performs such a task. 

Help would be much appreciated

Re: Smoothstepper ESS new setup failing to connect
« Reply #1 on: August 15, 2015, 01:30:48 PM »
I figured it out.  Standard copies of windows 7 and 8 apparently do not allow simultaneous connections to more than one IP address and my wireless internet and Ethernet port were essentially competing for that slot.  As soon as I disabled the built in wireless internet, the Smooth stepper was able to communicate as advertised to the board.  It was suggested to me that, for both to work, a solution to this problem is to install a Gigabit Ethernet card and get a gigabit router so that I can route both signals through the same line without having to worry about bandwidth conflict.  A gigabit is well above the requirements of both combined.  First I will try  to get a USB wireless adapter for my PC it might not to conflict with the Ethernet topology...?

Offline Jeff_Birt

  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Smoothstepper ESS new setup failing to connect
« Reply #2 on: August 28, 2015, 08:09:59 AM »
You can have multiple network adapter on any versions of Windows. What can happen is that the internal routing tables in the PC prevent windows from using the correct adapter. Rebooting the PC will usually fix this but on some occasions you may need to do a 'TCP/IP' reset. I use the built in WiFi to connect to my home network and the Ethernet adapter for the ESS have done this for years.
Happy machining , Jeff Birt
Re: Smoothstepper ESS new setup failing to connect
« Reply #3 on: October 20, 2015, 04:45:58 PM »
I have experienced this same problem even with only one NIC on my computer.