Hello Guest it is October 01, 2023, 03:29:32 PM

Author Topic: ESS, Home switches and pendants  (Read 5943 times)

0 Members and 1 Guest are viewing this topic.

ESS, Home switches and pendants
« on: August 13, 2015, 04:21:38 PM »
I'm kind of pulling my hair out on this: Mach 3 R3.043.066 won't home.

Here's my setup:

An ESS, (powered by a 5v power supply) with:
A CNC4PC C32 (R5.4) hooked up to ports 1 and 2 to handle talking to my step drivers, spindle VFD and a CNC4PC MPG4.
A CNC4PC A16 (25 pin header to DB25F, connected at one end to ESS Port 3 and an A42 (DB25M to RJ45) on the other, connected to an A32-4 (4 mechanical home/limit switches.)

Considering port3 only: It amounts to being only for the home switches on its pins 2, 3, 4 and 5 because the C32 can't run home switches and an MPG at the same time. (And in my infinite wisdom, I went and put the ESS/C32 in a case that is just big enough for it, a fan, cabling and the power supply: a port 3 BOB won't fit)

Sounds reasonable, right?
I can see the switch states change (when I toggle them) in the Mach3->plugin->data viewer page, and on the mach3 diagnostics screen. I can move the axes under NC control, using keyboard jogging and and using the MPG. But: I hit "Reference all home" to get the table aligned with MCS, nothing. It says it's moving, but the axis motors make a couple steps once each in sequence, blended speed goes up then drops to 0, no motion.

No limit switch contact. I've disabled soft limits: nope. Ensured everything was noise free: Nope. I even made a new Mach profile and tried again: Nada, Same symptoms. It's like Mach refuses to believe that the machine's physical coordinates are currently actually at X14Y3Z-3,when home switches are at X16Y6.5z0. Before I had the MPG installed, limit switches worked on 2_10, 2_12, 2_13 and 2_15.

Am I losing my mind here? Is it a Mach bug (unlikely, I think), a configuration problem, or is it an ESS bug?
Re: ESS, Home switches and pendants
« Reply #1 on: August 14, 2015, 08:39:15 AM »
I had all kinds of problems with the ESS, sent it back after a week or so. Almost impossible to get any support for it. I would classify it as a definite Beta product at this point and it doesn't look like that is gonna change for the Mach3 version anytime soon.
Re: ESS, Home switches and pendants
« Reply #2 on: August 15, 2015, 09:59:52 PM »
If I remember right homing is a function of the ess not Mach. Have you configured it there? Leave a message on the warp9 forum, andybis good about answering.
Re: ESS, Home switches and pendants
« Reply #3 on: August 15, 2015, 10:15:26 PM »
Also 066 isn't recommend for ess. See their website.
Re: ESS, Home switches and pendants
« Reply #4 on: August 17, 2015, 09:40:10 AM »
Mach 066 had problems and IMO should be removed. Warp 9 recommends using Mach 062. I have a ESS and PS3 pendant, running 062 with no issues. I do my homing in Mach 3 not via the SmoothStepper homing option in the ESS config page. I found using the SmoothStepper homing option I would get Mach "exceeded limits" error messages after the axis hit the homing switches. 
Re: ESS, Home switches and pendants
« Reply #5 on: August 17, 2015, 07:06:40 PM »
I switched to 062. Mach still won't home.

I put values into ESS' homing config (units 1, which ends up being 10.5 ipm (on a 100IPM max velocity config ?!), backoff speed 0.1 and index port and pins (3,2-5, active low) as required) page and checked enable. Now it moves, but it ignores the switches.

Mach says "g01 <axis><distance>" rather than "homing <axis>" Searching around suggested general config->debounce to 2. No change. I manually back off the axes a few inches, hit ref X Y or Z, then manually trigger that axis' home switch and it keeps right on trucking along. E-stop.

If I uncheck the "use this config" box in the ESS homing config page, I'm back to no motion on pressing "reference <all/axis> home".

Here's my current XML.
Re: ESS, Home switches and pendants
« Reply #6 on: August 18, 2015, 09:56:15 PM »
Ah! Sweet, glorious success!

Do not use the ESS homing config. Go instead into the ESS plugin config and set all options in "Noise filtering of inputs" to 2.0. It won't work out of the box without doing so.