Hello Guest it is May 20, 2019, 07:06:37 AM

Author Topic: PMDX-126 relay trouble  (Read 834 times)

0 Members and 1 Guest are viewing this topic.

PMDX-126 relay trouble
« on: August 10, 2015, 10:44:59 AM »
Hello,

I posted a while back about a 4 axis mill that I have been trying to set up for laser welding some of our lower power parts. I'll link the old thread below.

http://www.machsupport.com/forum/index.php/topic,24799.0.html

I have worked through nearly all of the issues with this project. The only thing I can't seem to figure out is how to get Mach3 to use the K1 and K2 relays on the PMDX to fire the laser.

I currently have the jumpers JP1 and JP2 set on pin "1" and "14" respectively, which is what OUTPUT1 and OUTPUT2 are set as on Mach3.

I've also set the spindle relays and flood mist control relays as output 1 and 2, so I could use the M-functions to control the laser output.

Whenever I run a simple program to test the functionality of the relays, I get no response from the LEDs on the PMDX.

If I move JP1 and JP2 back to the multimode setting and run the g-code, I get pin "1" and "14" on the J6 terminal to light correctly.

I don't know if there is a setting on the dip switches I am missing or something like that.

Any suggestions would be greatly appreciated.