Hello Guest it is November 14, 2019, 09:29:21 PM

Author Topic: Can't get spindle to turn on  (Read 4062 times)

0 Members and 1 Guest are viewing this topic.

Can't get spindle to turn on
« on: August 09, 2015, 06:25:52 PM »
I can not get a 10vdc signal on my analog output from my c32/ESS setup. I measure .4vdc constantly, but can not get anything else. I have tried to follow the manual, and no luck. I can get 10vdc to the analog, but only if I use step low active, but can not shut if off then unless I uncheck low active. When I do get that, it shows relay #1 active, if I check direction low active, relay #2 and axis 6 (rj45 port) show 1-14 and 1-16 are getting a signal. So it is obvious that I must have my pin setup wrong somehow.

I use mdi and type in s4000 m3 (top rpm) and it shows it should be running, but get nothing my my constant .4 volts.

I have tried several different setups, but this is what the manual says.
Motor outputs tab:
spindle enabled, step pin# 14, direction pin# 16, port 1 for both

It says nothing about outputs, so no change there

Spindle setup tab:
uncheck disable spindle relays
Clockwise (m3) output# 2
CCW (m4) output #1
not sure how these work and why the it states "outputs signals 1-6" when those are not valid outputs for port 1??? I thought they were only 2-9 on port 1 and 1,14,16 and 17 on port 2???
Motor control box:
check on Use spindle motor output
check on Step/dir motor

then I went to motor tuning
chose the spindle tab, turned up the velocity, moved accel to about 1/4, steps to 1000, step pulse 5, dir pulse 1.

Once I have this working correctly I can hook it up to my vfd (hitachi wj200) and deal with the "issues there", then I can actually start to cut some chips after having this mill for three years!

Please help, I am lost!
thanks
Re: Can't get spindle to turn on
« Reply #1 on: August 11, 2015, 07:07:29 PM »
Okay, progress. I now can get the relays on the c32 bob when I issue a m3/m4 command now that I know you had to go into the ESS config and turn on the dir/step there. Still can not get any volts(other than the constant .4vdc) out of the analog signal unless I set the step active low.
Re: Can't get spindle to turn on
« Reply #2 on: August 11, 2015, 08:18:29 PM »
more progress. Just messing around, I had set my spindle to 32khz in the ess config, then the pulse width to 40, and what do you know, I got voltage! I turned it up to 80 for the pulse width and I got my full 10vdc! Now time to hook it up to the Hitachi VFD and fight those issues.....
Re: Can't get spindle to turn on
« Reply #3 on: August 12, 2015, 07:23:15 PM »
Now I got the pulse width down to 28.8 as that is the lowest number that puts out 10vdc at 4000rpm command. Problem now is, when I put in the s2000 command it drops to 3.8vdc..... thought it would be proportional...... How to fix this?
Re: Can't get spindle to turn on
« Reply #4 on: November 08, 2015, 10:04:00 AM »
Thanks for sharing your troubleshooting progression - very helpful!  I now find myself in a similar situation.  Could you share your final configuration of Mach + ESS + C32 + VFD?

-Chris.
Re: Can't get spindle to turn on
« Reply #5 on: November 08, 2015, 11:51:43 AM »
I can, but it may be a week or two. I have my rpm match pretty well from 1200-3000rpm, but under that is way off. I have lost motivation on this project, been thinking of selling so progress is VERY slow. I will post back when I get the info