Hello Guest it is November 23, 2020, 07:08:41 PM

Author Topic: After install newer mach3 version stuttering movement  (Read 4602 times)

0 Members and 1 Guest are viewing this topic.

After install newer mach3 version stuttering movement
« on: July 24, 2015, 04:38:15 AM »
Good day,

Im jef from The Netherlands. And just busy with cnc a small year so im still a cnc noob mostly  :)

I have a problem with mach3. I had an older version of mach3 and that worked but i found out i couldnt change step en dir pulse setting so i bought the newest mach3 (3.043.066) and installed it.

I copied all old settings that worked to the new mach3  mill XML.

Now i could change the step en dir pulse to 4.

Problem i have now is that the movements are stuttery just like it pauzes really fast, the machine is not shaking but i can see and feel it more or less. This problem i did not have with the old mach3 version.

CV i checked at first but it was on CV mode, all other CV options unchecked in CV control. Lookahead on 200lines. Also on settings screen CV distance and feedrate are unchecked. Backlash is disabled also.

I then reinstalled the old version 3.041 which came with the machine when i bought it.

Ran the same gcode, smooth like butter movements, cranked the feedrate some higher and still smooth movements.

So it has got to do with settings new installed version, but i doublechecked and there are no differences in settings.

What could this be?

ps: gcode file enclosed
« Last Edit: July 24, 2015, 04:47:04 AM by gobbya »
Re: After install newer mach3 version stuttering movement
« Reply #1 on: July 24, 2015, 05:01:13 AM »
Here are my settings in mach3
Re: After install newer mach3 version stuttering movement
« Reply #2 on: July 24, 2015, 10:23:27 AM »
Here two videos i made. movement with 3.066 vs 3.041 all same settings. Only difference 3.041 smooth movement 3.066 stuttering movements.

https://www.youtube.com/watch?v=qHI-h6yhiYg   3.066 stutter

https://www.youtube.com/watch?v=UOCeDS_VfwU   3.041 smooth.

Im running windows7 64bit btw. i7-930, 3,4Ghz, 6gb ram.

Offline Tweakie.CNC

*
  • *
  •  8,549 8,549
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: After install newer mach3 version stuttering movement
« Reply #3 on: July 24, 2015, 10:55:43 AM »
Curious one this - which motion controller are you using ??

Tweakie.
KEEP SAFE !
Re: After install newer mach3 version stuttering movement
« Reply #4 on: July 24, 2015, 12:09:06 PM »
Im using the 4axis leafboy77 usb card. AKZ250.
« Last Edit: July 24, 2015, 12:10:40 PM by gobbya »

Offline BR549

*
  •  6,939 6,939
    • View Profile
Re: After install newer mach3 version stuttering movement
« Reply #5 on: July 24, 2015, 12:34:51 PM »
V.066 is KNOWN to be a bad version .

(;-) TP
Re: After install newer mach3 version stuttering movement
« Reply #6 on: July 24, 2015, 02:36:59 PM »
Ah ok i did not knew. I tried few older but same problem stays.

Offline Tweakie.CNC

*
  • *
  •  8,549 8,549
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: After install newer mach3 version stuttering movement
« Reply #7 on: July 25, 2015, 03:32:35 AM »
I suspect the problem lies with the Leafboy as it's USB / driver software has been tailored to the earlier versions of Mach3. Their website says it is suitable for use with Mach3 R3,043.066 and it may be worth downloading their latest plugin and seeing if it makes any difference.  http://leafboy77.com/index.php/en/home/16-english-categories/mach3/usb-motion/card-akz250/1-mach3-usb-motion-card-akz250

It may also be worth contacting the manufacturers and asking the question.

Tweakie.
« Last Edit: July 25, 2015, 03:49:09 AM by Tweakie.CNC »
KEEP SAFE !
Re: After install newer mach3 version stuttering movement
« Reply #8 on: July 25, 2015, 11:07:30 AM »
Hi Tweakie,

I guess you are right about this. I made sure and checked my usbmove.dll version and installed the latest. The latest version is 2.01.9 30-3-2013. They say it works with latest mach 3.043.066 but nono it works almost haha.

Then i tried installing mach3.042.040 and now the movements are smooth again!

Wish they make a new updated usbmove.dl. I couldn't find any contact info on leafboy site unfortunately.

But it works now with the above mentioned version of mach3.

l
Re: After install newer mach3 version stuttering movement
« Reply #9 on: August 19, 2015, 07:54:01 AM »
Just to say, I've discovered exactly the same problem with version 3.043.066 using Parallel Port today. Maybe its not your USB controller?

Trying lots of CV settings and motor tuning makes no improvement with my new machine build. I've been running an old GCode file that worked fine on my old CNC mill (running an older Mach 3). So, I think this post helped me work out the issue, I will try an older version of Mach3 and report back. I've read stacks of posts on CV and I think it should be smooth with CV tuned, certainly others have said they achieve smooth motion after tweaking these settings, but its not always clear what Mach3 version they are using.

Surprising (if so) to see such a fundamental issue with this "final" version? Hasn't anyone else seen this issue?  Hence, I'm still not sure that isn't me doing something wrong, but as Gobbya found, the settings don't seem to change this behaviour. It feels like CV is not on, but it certainly says it is.  Any advice gratefully received.

Just to be clear, in my case, Mach3 is pausing ever so slightly at the end of every straight line even when it is a straight line, just split for no reason by the CAM programme. Surely this should be smooth with CV on? I'm going to test 360 deg circles next. I'm guessing its going to slightly pause at each node... No backlash and quite high acceleration motor settings.

Woody