Hello Guest it is August 18, 2019, 02:00:27 PM

Author Topic: Help! Dangerous Result With Mach3 And Vista Pendant  (Read 5049 times)

0 Members and 1 Guest are viewing this topic.

Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #10 on: July 28, 2015, 07:11:42 PM »
Are you referring to the P.4? I thought that was a pause of .4 seconds duration. Is that not true?

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #11 on: July 28, 2015, 07:54:26 PM »
Not used in that context. I would have to see the macro code to know exactly what it was used for. It cold be a puase or anything else in the code.   With each Mcode you have up to 3 paramaters that you can call with teh macro PQR.

A gcode pause would be G04 Pxx. The G04 is the pause and teh Pxx is the duration.

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #12 on: July 28, 2015, 07:56:58 PM »
AS a test I would unload the plugin and run the test from the keyboard..

(;-) TP
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #13 on: July 29, 2015, 01:46:10 PM »
Thanks again for responding!

I restructured the program so that the pauses are like this:

M3
G04P.4
M8
G04P.4
etc.

I also removed the plugin from the Mach3 folder. This was in addition to deactivating it in the configuration screen.

The problem is still there. It is very persistent!

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #14 on: July 29, 2015, 02:00:58 PM »
OK lets start from teh top. When the Gcode STOPS for the M1 and then you press Cycle Start to resume it restarts in G00 mode and stays there ? It does not even change modes on the very next G1 call ??

You stated earlier than it ran FINE from the keyboard and the problem was when you did it from the pendant. WHICH is it ??

IS this a LPT version or do you run an outside controller ??

(;-) TP
« Last Edit: July 29, 2015, 02:04:08 PM by BR549 »
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #15 on: July 29, 2015, 02:52:22 PM »
If I'm running from the Mach3 screen (no pendant), and I restart from an M1 or M0 by clicking on the "Cycle Start" button everything works fine through the whole program.

If I'm running from the pendant, due to the dual purpose of the start/hold position of the selector switch, I have to click "Hold" before "Start". There is no choice in the matter that I can see. And this is when all subsequent feed moves become rapid moves. Even when running the program again from the start. It then has nothing to do with M1s or M0s. The only way to clear it is to exit Mach3 and restart it.

What is interesting to me, is that if I am running without the pendant and press "Hold", then "Start" to move past an M1 or M0, it does the same thing. So, is it a bug in Mach3 or has has the Vista plugin corrupted Mach3? Your result points to a plugin problem, don't you think?

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #16 on: July 29, 2015, 05:23:23 PM »
HIYA Mike I cannot get it to fail HERE in that mode no matter WHAT I throw at it. It allways follows the modal state precisely. What I would try NEXT is to recreate teh config file from scratch DO NOT reload a XML backup. Start from scratch and plugin all the numbers by hand. THEN rerun the senario.

I will keep testing here to see IF I can get it to fail in ANY way.

(;-) TP

Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #17 on: July 29, 2015, 06:44:27 PM »
Are you referring to the general config popup in the config menu? I don't see a way to reconfigure that from scratch other than installing a fresh copy of Mach3.
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #18 on: July 30, 2015, 10:30:19 PM »
OK, here is the latest in my Vista P2S pendant and Mach3 saga. I started from a totally new Mach3. A time consuming process for sure. Lots of things to set.

But the bottom line is, it now works fine! No more rapid moves that were intended to be feed moves.

Evidentally the Vista P2S pendant plugin corrupts Mach3. And in a potentially dangerous way. Especially if you are running something like a mill or lathe. If you are running a machine like this with a Vista P2S pendant installed, please be careful and try your new programs cutting air only.

I plan to return this Vista P2S pendant. Does anyone know of a good pendant that works with Mach3?

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: Help! Dangerous Result With Mach3 And Vista Pendant
« Reply #19 on: July 30, 2015, 11:06:17 PM »
HOLD ON THERE big dawg. you are not done yet (;-) NOW you need to reinstall the pendant and see IF the problem returns. FIRST same the XML off to a safe place so IF it does you can simpley delete the current XML and install teh GOOD xml.

IT could have been a corrupt XML causing the problem.   

Just a thought, (;-) TP