Hello Guest it is November 14, 2019, 11:01:56 AM

Author Topic: Difficulties in testing gcode strings off line  (Read 4852 times)

0 Members and 1 Guest are viewing this topic.

Difficulties in testing gcode strings off line
« on: June 30, 2015, 02:12:21 PM »
Hi. When I have my computer connected to the mill testing of gcode strings work perfectly well. When I load the same string when the computer i disconnected it doesn't work. When I disconnect the motion card from the mill and bring it to my studio and connect it to the computer, it all works well. But I don't want to do this every time I'm going to test strings. What's wrong and what can I do to make this work?

Regards
Stein
Re: Difficulties in testing gcode strings off line
« Reply #1 on: August 02, 2015, 04:17:14 AM »
Hi  Stein,
when you say it doesn't work what exactly do you mean? It just sounded a bit like the difference between 'run mode' and
'simulation mode'.
I don't have a motion controller but I use my indoor computer for simulation no trouble.

Craig
My wife left with my best friend...
     and I miss him!

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: Difficulties in testing gcode strings off line
« Reply #2 on: August 02, 2015, 05:08:37 AM »
you need to set up another copy of M3 on another computer so you can sim your code it works only with the motion controller as it will be looking for that when you try to sim some code.

or another way that might work set up another profile from scratch don`t copy the existing profile call it sim don`t load the motion controller plugin just have all the settings there just no plugin it may work that way.