Hello Guest it is June 02, 2023, 12:01:58 PM

Author Topic: Motors will lock but will not turn  (Read 4381 times)

0 Members and 1 Guest are viewing this topic.

Motors will lock but will not turn
« on: June 23, 2015, 02:05:49 AM »
I have purchased a Joes 2006 with a Hobby CNC motor controller.  I had a Windows 7/64 bit computer that I know will not work with Mach 3.  I installed a hard drive, loaded XP (sp3) and I added a parallel port card.

I have completed a successful Test Drive and Mach 3 says it is in control.

I have found the correct pin configuration for my motors (X2,3, y4,5, z6,7) and I have LPT1 communicating (I can reset the estop and it will stop blinking.)

I cannot get it to run...the motors are loaded (wont turn by hand) and getting warm and if I pull the parallel cable or turn off the computer I do get a distinct clunk from the CNC.  I have tried entering Gcode directly also.

This machine did work successfully on an older XP machine (person I bought it from).

Is the computer having a 64 bit processor, even though it is running XP, my issue? 

If I purchase MACH4, and use the parallel port plug in, should that work on my computer?  I understand it will be slow and I will  need to either get a new motor controller or purchase the smooth stepper but I really just want to make it run a little and then I wlill go for perfomance.

Re: Motors will lock but will not turn
« Reply #1 on: June 23, 2015, 07:03:41 AM »
If you have a Hobby CNC controller and you pulled the cable while it was energised you have probably blown one if not all of the Control chips.
The processor being 64Bit is not the issue. I would be checking the Parallel port card settings. IE Standard, EPP, ECP maybe. Also double check the wiring and the Step Dir Active is ticked in the Config page.

I use the HobbyPro CNC Controller without issues.

Re: Motors will lock but will not turn
« Reply #2 on: June 23, 2015, 07:44:45 PM »
Not all modern parallel cards have the correct output voltage to drive all BOBs, check your card's output voltage and your BOB's requirement,

 - Nick
Re: Motors will lock but will not turn
« Reply #3 on: June 23, 2015, 08:06:43 PM »
Rosewill RC-302 Parallel adapter...says it outputs at 5v...
Re: Motors will lock but will not turn
« Reply #4 on: June 23, 2015, 11:46:11 PM »
Just had a quick check of the Specs

Easy Plug and Play installation
Automatically selects IRQ & IO address
Supports IRQ sharing
Multi – card capability – allow for upgrade with additional serial or parallel cards
For 5V PCI slot only

Notice it has IRQ sharing - not a good thing. See if you can manually set the IRQ and IO address.
Also it is for the older 5V PCI slots, check your PCI slots are 5v ones and not 3.3V otherwise you will not have 5V

Re: Motors will lock but will not turn
« Reply #5 on: June 24, 2015, 12:31:00 AM »

Thanks for the responses.  I am getting 5v at pins 1,2,3,4,5 etc.  My X is on step 2 dir 3 and when I clicked active low on and off I was not able to get any state other than 5v...I could not get any voltage lower than 5v no matter what I tried....I am going to try another card or buy a used computer with XP and a parallel card built in...


Re: Motors will lock but will not turn
« Reply #6 on: June 24, 2015, 02:55:46 AM »
Hi Mark,
Changing the Pin states in the Port settings doesn't alter there state only the trigger point from leading edge to trailing edge. The Gcode triggers the state from 0 to 5v.
I have attached my Hobby Pro CNC set-up XML(In the zip File) you can try. Just note the settings and trial them.
I Use 5MM ball screws with a 3:1 reduction so the steps etc. will be different to yours.
Also I have included a shot of the Pin assignment. I believe the only difference between the Hobby and HobbyPro is the A axis.

Word to the wise, try  the settings with the CV_TEST_CODE.tap file I have included, no tools in the system and check the Max settings are within limits and be ready to hit the space bar or the emergency stop.. If it is anywhere near right the units will sing to you ;-)
Let Us know how you go