Hello Guest it is October 16, 2019, 09:11:12 PM

Author Topic: Backlash compensation causes non constant feed  (Read 3786 times)

0 Members and 1 Guest are viewing this topic.

Backlash compensation causes non constant feed
« on: April 26, 2007, 02:33:50 PM »
I am new to Mach3.  I have used it to control my 3 axis machine.  I am trying to use the backlash compensation.  When I activate backlash compensation the compensation is applied to the reversing axis but at the same time the other axis slows to a stop and then accelerates.  This causes the feed rate on a circular move to be non constant.  Is there anything that can be done?

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Re: Backlash compensation causes non constant feed
« Reply #1 on: April 26, 2007, 03:02:59 PM »
Hey CNCMay,
    Can you post a picture of the cut it is making when it does this? Also, how much backlash do you have to compensate for and what version of Mach are you running? Mach 3 ?.0.0??

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Backlash compensation causes non constant feed
« Reply #2 on: April 26, 2007, 07:05:21 PM »
My machine has conventional leadscrews and therefore has alot of backlash, at the moment I estimate about 0.45mm per axis.  The version of Mach3 I have is R.2.0.061.  I will attach a jpeg of a ballbar plot I have produced on the machine with the backlash compensation set to 0.45mm and enabled.  I think the odd forms at the quadrants are an artefact of the broblem I am experiencing with the non reversing axis slowing to a stop as the other axis applies the backlash.  (The ballbar expects constant feed.)  I have tried circular moves with the backlash comp. disabled an I then do not experience the problem.

Any ideas?

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Re: Backlash compensation causes non constant feed
« Reply #3 on: April 27, 2007, 08:15:34 PM »
Quote
Hi:

Actually, Backlash works in CV now as well. Set your config/general shuttle accel to .1 , see if that makes a difference. It will seem as if there is too much backlash, but thats only because backlash now ramps to zero before
applying backlash. Its now safe in all runs, but the setting of that accel will setermine how long it tales to ramp to zero.

Art


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Graham Waterworth

*
  • *
  •  1,889 1,889
  • Yorkshire Dales, England
    • View Profile
Re: Backlash compensation causes non constant feed
« Reply #4 on: April 28, 2007, 01:44:46 AM »
Going by your plot,

it looks to me that you have too much compensation set, if you are getting a straight line at the quadrant points the axis compensation is moving the table not taking up the backlash, reduce the amount of compensation and try again.

Graham.
Without engineers the world stops
Re: Backlash compensation causes non constant feed
« Reply #5 on: May 02, 2007, 03:41:30 PM »
Thanks for your help Graham and Brett. 

I did have too much compensation set and the shuttle accel 0.1 has helped with the dwell on the non reversing axis.  I was already in CV mode.  I do still get a dwell and the ballbar plot is showing reversal spikes, I am wondering if these may be due to the dwell. Why does the nonreversing axis have to dwell anyway? I will post a new plot so you can see how things have improved.  You will see from the summaries there are still some areas for me to work on. 

What is shuttle accel. anyway I did not understand the explanation in the Mach3 manual?