Hello Guest it is May 24, 2019, 11:46:17 PM

Author Topic: Wrong position  (Read 1178 times)

0 Members and 1 Guest are viewing this topic.

Wrong position
« on: June 06, 2015, 02:43:36 PM »
I have had Mach 3 set up on my Tree journeyman for years. Have done all kinds of crazy things with it with very few issues. Today I was thread milling a small shaft with a thread mill. It is a two pass program with two simple helical interpolations. I ran about a half dozen parts with no problem and was adjusting the feed in Gcode of the interpolations to optimize the cut time.
It made the first interpolation fine but instead of retracting to X-0.5 on the second pass it tried going to X-0.26!$% something at rapid and just snapped the thread mill off?
Once i seen it snap the cutter I hit feed hold and then stopped the program and the Mach 3 on screen DRO was at the crazy -0.26!$%.
Why the heck would it do that? I have never had it do anything like that before.
Would it be a computer hardware issue? Has any one else had this happen?
It concerns me because thread mills are not cheap and certain parts I make and work on are very expensive.

Thanks  

G40 G49 G50 G80
G90.1
( 0.375 DIA 20 PITCH THREAD MILL )
T12M6
M3S1400.000

G00Z0.5
G00X-0.5Y0.000
G00Z-0.90
G01X-0.375F7.000
G02X-0.375Y0.000Z-0.950I0.0J0.0F14.000
G00X-0.5      (<---------------------------------------- This is where it went buggy !!!!! )
G00Z-0.900
G01 X-0.365F5.000
G02X-0.365Y0.000Z-0.950I0.0J0.0F12.000
G00X-0.5
G00Z0.5
M30
M5

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: Wrong position
« Reply #1 on: June 06, 2015, 02:55:30 PM »
YEP It happen sometimes . I call it the Lost Mach Syndrome (LMS).  You MAY want to replace your Memory moduals in the PC you may have a bad BIT of storage that can throw everything out of whack. I have seen that stop a lot of the LMS in certain cases.

OR at least HAVE the memory  tested in your PC. Look for bad bits.

Also the G02 arc has been a concern with offsets in certain situations like Tool Comp causing it to wonder off so it may effect other things as well.

In some cases Pwering DOWN teh PC then restarting the PC and Mach3 helps UNTIL the next time it happens.  That also can point to memory problems in the PC

What version of Mach3 are you running ?

(;-) TP
« Last Edit: June 06, 2015, 02:58:03 PM by BR549 »
Re: Wrong position
« Reply #2 on: June 06, 2015, 03:11:35 PM »
The computer is getting pretty old and it wouldn't surprise me if it had a few bits of bad memory. I think I will check that out first as its probably getting time to replace the old PC with a newer one.
I know there are issues with the cutter comp so i always just change the code.
It is version 2.0

Thanks for the response at least I know I am still somewhat sane. :)