Hello Guest it is December 06, 2019, 01:33:05 PM

Author Topic: Abnormal Condition, limits switches not working after trying to set Soft limits  (Read 1455 times)

0 Members and 1 Guest are viewing this topic.

Hi all,

My machine is now jogging slowly and the limit switches do not work anymore after I tried to set soft limits for it in Mach3.

This is the article I was following for setting the soft limits,http://www.instructables.com/id/Setting-Soft-Limits-for-your-Industrial-CNC-Router/.
By the way, I did not manage to set the soft limits successfully.

Also, Mach3 is now showing the Abnormal Condition message and the following is in the list of abnormalities,
-One or more axis enabled or disabled
-Exact Stop vs CV mode
-Axis are not refed to normal condition

There is 1 Meder limit switch(magnetic/electronic) on each axis of my machine.
2 stepper motors on X axis, 1 on Y and Z axis.

I have reinstalled Mach3 many times but the problem just won't go away.

I'm very new to CNC milling I would really appreciate any help to resolve this issue. Thank you in advance!!

I tried the below but no luck so far,
- changing the Debounce Interval
- change the Activelow pin setting for EStop
- checked the physical wiring on the limit switch

Offline dude1

*
  •  1,253 1,253
    • View Profile
look through the M3 manual for how to do it. all so what happens when you turn soft limits of, are all the switches wired the same
Hi guys,

Just an update on the cause of the problem. It is due to the unstable signal on the LPT port of my PC.

I decided to buy a SmoothStepper(ethernet version) after determining that all Mach3 configuration and wiring are done correctly.
Added the Smoothstepper and all my problem are gone and the mill is so much smoother than before.