Hello Guest it is October 14, 2019, 12:09:03 AM

Author Topic: 'pause while not cyclestart' macro that worked now 'terminating scripts'  (Read 1451 times)

0 Members and 1 Guest are viewing this topic.

This macro is called from the 8th line of a gcode file. I've stripped out all the non problematic code, and I'm left with

Message "halt"
Sleep 1000

DoOEMbutton(1003)
While Not GetLED(4)
Wend

Code "M98 P113"


The first 2, and last lines are not strictly necessary, (just there in case anyone thinks it's a pointless macro...) it worked fine before, but today the same thing happens on each run :- 'Terminating scripts'.

I close Mach, try to reopen; clicking/double/triple clicking machloader does nothing. Trying to modify and save the macro that was open in notepad gives a message that 'this is being used by another program', and shutting down the PC for a restart as last resort gives a message about 'DDE Server Window still being in use.

This macro worked fine a week or 2 back  (it's never had 'End' on the end), why has it suddenly gone weird?

M21
BTW this works from VB editor in Mach, stepping through and running. No odd behaviour necessitating a restart either.
Seem to have found the source of this; when I reloaded Mach last, I accidentally loaded a previous version of Mach to the 3.043.053 that I was running before, Apparently the older one doesn't recognise 'While Not GetLed(n)' as valid code. Problem solved.

When I buy a licenced version of Mach, can I use the licence to run an older version of mach than the current release?
« Last Edit: May 29, 2015, 03:20:51 PM by moorea21 »

Offline BR549

*
  •  6,902 6,902
    • View Profile
Yes you can.

(;-) TP