Hello Guest it is September 27, 2020, 02:01:57 PM

Author Topic: ESS and poor motor response  (Read 8068 times)

0 Members and 1 Guest are viewing this topic.

ESS and poor motor response
« on: May 26, 2015, 03:59:51 PM »
 I found the ESS install & configuration instructions for my steppers on  the cncrouterparts.com website and followed it step by step. I  have motor motion, however, the Y axis (with the slaved A motor) and the X axis run hot, slow and rough.  The Z axis runs smooth and quiet. Can anyone help to smooth out these motors? Is my Dell laptop causing the problem in any way? Did I get a bad ESS board? If I connect to my turtle-slow Win XP desktop, the steppers run fine. Thank you.
Re: ESS and poor motor response
« Reply #1 on: May 30, 2015, 08:12:07 PM »
I have a 48V power supply. Mine is a 7.3 A. I understand I need a 12.5 A. to run 4 steppers. My system worked just fine (other than being extremely slow) until I switched from a Win XP desktop to a Win 7 laptop and added the Ethernet SmoothStepper. Now all of a sudden the NEMA 23 steppers are running hot,slow and rough. The Z axis, a NEMA 17, runs just fine.So can anyone explain why things changed by adding the ESS?

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: ESS and poor motor response
« Reply #2 on: May 30, 2015, 08:35:45 PM »
have you got the motors set correctly in ESS setup if you have them set wrong it can make them run like a bag of ********* as in this

If the SmoothStepper has its 'Max Step Frequency' set too high for an axis it will limit the output resolution for that axis.

You can get an idea of what this frequency should be set to by knowing your steps/unit and max velocity.

Steps/Unit * Units/Min = Steps/Min Steps/Min / 60 = Steps/Second (or Max Step Frequency)

This Steps/Second is the needed step frequency for that Axis, you should set the SmoothStepper’s 'Max Step Frequency' to the lowest value that is equal to or greater than your Steps/Second.

Once you get all your axis' 'Max Step Frequency' set, adjust the 'Controller Frequency' to the lowest value that proved Smooth movement, the note on the SmoothStepper configuration page says higher settings will limit resolution.

I have attached the new ESS manual

Offline ger21

*
  • *
  •  6,285 6,285
    • View Profile
    • The CNC Woodworker
Re: ESS and poor motor response
« Reply #3 on: May 31, 2015, 07:26:15 AM »
What size are the other motors? What drives are you using? If you have a Nema 17 on the Z axis, than I can't believe that you'd need 12.5 amps. 7 amps should be plenty, but I'd need more information.

Are the acceleration and velocity settings the same on both PC's? And no settings on the drives have been made, but just switching PC's makes the difference?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: ESS and poor motor response
« Reply #4 on: May 31, 2015, 03:09:20 PM »
Here's what I have and what I've done:

I built the OX CNC from Openbuilds.com

Electronics kit fromcrcrouterparts.com:
48V 7.3A switching power supply
Gecko G540 4 axis stepper motor driver
3 High-torque Nema 23 380 oz-in stepper motors,
3 High-performance flexible motor cables: (1) 6'and (2) 12' cables
Bought 1 extra cable and a NEMA 17 stepper for the Z axis


I'm thinking the problem is with a setting somewhere but I thought that by downloading the XML and v10da files, this makes the necessary settings for Mach3 to work properly. (Apparently Not)

Now keep in mind I'm not a CNC router or computer Guru. I'm just a woodworker who likes to make things. All these ESS settings are driving me crazy!

This system ran well and I did a few projects on my Win XP desktop. The system was so slow it drove me crazy. Every time I clicked on something it would take forever to execute it. I cleaned off the C drive and re-loaded everything. Still slow.So I switch to a Dell laptop and the Ess.

I downloaded and installed the proper XML file from crcrouterparts.com (verified) and the Ess-v10da2 file from Warp9. I set the IP address (10-9-9-1) and subnet mask (255-255-255-0)  I set the Windows firewall according to directions. I open the Mach3 loader and choose the xml file. When prompted, I choose the v10a2.  I now have the X axis moving on it's own as soon as Mach opens until I hit the arrow key (it stops) The motors now move faster and smoother except for the first second or two on the Y axis. It still has a grinding as it starts and stops but runs better back and forth than it did before. The z azis seems to run fine. My DRO for X,Y & A are red and will not go to green. I can however  move the motors with the arrow keys. In Mach3/plugins/homing dialog everything is set to 0. I'd attach a screenshot but I don't know how. :-[  What else do you need to know? I'm beginning to wonder if I wasted $200.

Offline ger21

*
  • *
  •  6,285 6,285
    • View Profile
    • The CNC Woodworker
Re: ESS and poor motor response
« Reply #5 on: May 31, 2015, 07:15:35 PM »
Don't assume that the .xml file has all the correct settings for your machine. The CNC Routerparts .xml file contains settings that work with their machine, not yours.

I'd recommend starting with a completely new profile, and setting up everything yourself correctly.

If you want your machine to run correctly, you're going to have to learn how to do it.

Quote
The motors now move faster and smoother except for the first second or two on the Y axis. It still has a grinding as it starts and stops but runs better back and forth than it did before.

It sounds like you may have incorrect steps/unit settings, and acceleration and velocity settings that don't work with your machine. Acceleration and velocity need to be set using a trial and error process.
Quote
My DRO for X,Y & A are red and will not go to green

This sounds like the machine is configured to possibly use home switches, and you don't have any?

All of these issues can be from using an .xml file that doesn't match your machine.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: ESS and poor motor response
« Reply #6 on: June 02, 2015, 01:54:51 PM »
I GIVE UP. I've tried everything. I created a new profile - I even removed Mach3  the ESS plug-in and the XML file I downloaded from my computer, Started fresh. Still doesn't work. Hooked it back up to my XP computer and works fine. I have to think it's the Win 7 platform. Anyone want to buy a Ethernet SmoothStepper?  :'(
Re: ESS and poor motor response
« Reply #7 on: June 02, 2015, 04:00:10 PM »
Thank You to everyone who tried to help me with this problem. I appreciate all your comments and suggestions.

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: ESS and poor motor response
« Reply #8 on: June 02, 2015, 05:52:26 PM »
I have run a ESS on two different win 7 laptop`s never had a problem
Re: ESS and poor motor response
« Reply #9 on: June 02, 2015, 07:40:55 PM »
I don't know what the problem is. I've tried several times and follow the directions. I can't get the X & Y motors to run smooth and at a decent speed. I wish I had someone local to stop over and get this thing to run properly. Oh well. >:(