Hello Guest it is June 16, 2019, 01:26:22 AM

Author Topic: Hallo, just another one with a spindel problem  (Read 1342 times)

0 Members and 1 Guest are viewing this topic.

Hallo, just another one with a spindel problem
« on: May 24, 2015, 04:14:41 AM »
Hello.
I am Wilco from Holland.
Ten years ago i had a big acident on my motorbike and lost a leg.
Sad but my head was still working so....
A artificial leg and go on with life, but there was a little problem.
the legs they made for me were horrible.
So  i decided to make one my own.
Bought a lath, a  Colester Master 2500 from England and a bridgeport and a old CNC Kondia mill and started trying to make mij own leg?
Happy for me i found someone how made a good leg.
Lost my leg and motorbike hobby but fond  a new hobby, milling and CNC.
So far, my Kondia is running perfect on Mach3. now i am trying to get my Colyester run on Mach3.
The axes are no problem but i like to do the treading on the lathe and for that i have connect the spindel to Mach3.
A that won't work, i can not vind a good manner.
Please can you help me.
For now,I'm Duch  i have a Englisch lathe a Chinees breakoutboard and a Software from USA but they have to talk to eachother.
Looks simpel, bought a encoder from a lokal shop, 5 wires  a red one for power +, a black one for power -,
a green and a white one for the multi counting and a yellow one vor single counting.
What i  do what i do, nothing works.
What works is my VFD, did get to manage to configure the RMP  in Mach3.
Not stil the right RPM but hope to get it right when i can readout the spindel speed.
Can you help me?
Sorry for my horrible englisch, never finist school.
Can give more information and picture's when neded.
Please, i am a panel beater and no electrician so make it Jip and Janneke language for me.
Hope for the solution!
Greetings,Wilco Vervoorn
E-mail rmsvervoorn@caiway.nl






 
 

Offline RICH

*
  • *
  •  7,337 7,337
    • View Profile
Re: Hallo, just another one with a spindel problem
« Reply #1 on: May 24, 2015, 05:46:34 AM »
Wilco,

You will find in members doc's a write up called Threading on the Lathe. There is lots of good info in it and suggest you have a read.

Manualy set the rpm on the vfd for threading. Mach needs a signal to read the rpm so index is used.
I suggest you post info on your VFD and breakout board so one can better help you.
Also post your XML file.
What version of Mach3 are you using?

RICH
Re: Hallo, just another one with a spindel problem
« Reply #2 on: May 24, 2015, 07:03:15 AM »
Heej Rich,
Thanks for responding.
Unfortunately i am not so handy using the forum.
for a lot of the people here is normal to know how it works, but for me, yesterday i found out were the button off the PC was and this moring it managed to ask a question in the forum but how i did that?? , that's not al my englisch is not so good so please have a little patience with me.
First question: Members doc's? were can i find them?
How can i send a picture in a reply, i tried but?
the Mach3 version i am using is R3.043.066 (is this right?)
XML File? looked in the mach3 folder but couldnot find it.
Breakout board is from China, i recently bought it, changed it for my old board what was working with a parrallepoort and now its working with USB (aliexpres Xhc bord from martathome).
My VFD is a AF500 from Sumitomo, is a older one. i can send a picture of de conecting diagram (if posible and when i know how). with the output signal from the board i can settle the RPM speed now.
Oke..
Hope that you can help me further to get it working...
Greets,Wilco



Offline RICH

*
  • *
  •  7,337 7,337
    • View Profile
Re: Hallo, just another one with a spindel problem
« Reply #3 on: May 24, 2015, 09:33:35 AM »
threading on the lathe writeup link:

http://www.machsupport.com/forum/index.php/topic,13017.0.html

To attach a picture:
Below the reply box click the Preview button, in the window that opens
click the Additional Options, then in the new window by attach click the
Browse button (more attachments) and select the file that you want to
attach. Note only 4 allowed per rply and max allowed is 6000KB.

Rev 3.043.066 is reported to be buggy and not recomended.
Try something greater than .038 to .052....

The xml file is in the Mach3 directory. There will be one for the lathe,
the delfault one when Mach is loaded is Mach3Turn.xml. You want to post
the one that you are actualy using, so if you created a new one with a different name,
post that one.

For the breakout board post the manual for it. I personaly will not respond to
anything having to do with Chinese stuff as it just wastes my time and there are usualy
problems wit their junk. ( sorry just my opinion based on experience). So others will repsond.

RICH