Hello Guest it is September 16, 2019, 07:13:19 PM

Author Topic: CNC plasma setup help :)  (Read 2362 times)

0 Members and 1 Guest are viewing this topic.

Offline mike^3

*
  •  117 117
    • View Profile
CNC plasma setup help :)
« on: May 18, 2015, 02:59:27 PM »
 :D

Hello everyone! :)

I am having some issues setting up my cnc plasma cutter.

1) I use sheetcam and post process it with mach 3. The challenge is how do I set up the auto tool touch off for each pierce and start? For example start program, goto where z- to start cut would be, go down z- till input 1 is closed (or receives 5v, its a limit switch). then lift off plate when input 1 is open (no longer triggered) reset DRO z to 0, and then continue with the gcode (i am assuming the piercing hieght will be used from the gcode that i set within sheetcam).

2) I have a proma thc coming in soon. how do I set the parameters in mach3 to use this effectively?

Thank you so much everyone!

Offline BR549

*
  •  6,887 6,887
    • View Profile
Re: CNC plasma setup help :)
« Reply #1 on: May 18, 2015, 03:26:33 PM »
You need to use a POST  that is designed for the purpose of using the TOM (Top Of Material) Function.

Then you need to set up Mach3 to use either the G28.1 function OR the G31 function to run the TOM. The PSOT you use wil depend on the method you use G28.1 or G31.

The Proma SHOULD have instructions.

(;-) TP

(;-) TP

Offline mike^3

*
  •  117 117
    • View Profile
Re: CNC plasma setup help :)
« Reply #2 on: May 18, 2015, 05:24:34 PM »
Gotcha it hasn't come in yet so im kinda waiting lol.

But on a side note,

I can't get my digitize switch to work with mach.

I have a normally closed switch when the head touches the material it opens the switch. I have confirmed that the switch and wires are good to the break out board reading open  when it's triggered, I connected it like my other limit switches, one side to pin 10 for example and the other to ground, tried 5v too, mach doesn't register it in the diagnostic screen but sees my other switches when triggered, they are all the same switch type, any ideas?

Offline BR549

*
  •  6,887 6,887
    • View Profile
Re: CNC plasma setup help :)
« Reply #3 on: May 18, 2015, 06:27:17 PM »
Double check your Port and Pin settings for THAT switch . When tripped you SHOULD see a change in the Probe LED on the diagnostics page.

(;-) TP

Offline mike^3

*
  •  117 117
    • View Profile
Re: CNC plasma setup help :)
« Reply #4 on: May 18, 2015, 06:36:09 PM »
I did, I even changed it from 12, no work, 10, no work, 11, no work... and no stat change on the diagnostic page....

Offline BR549

*
  •  6,887 6,887
    • View Profile
Re: CNC plasma setup help :)
« Reply #5 on: May 18, 2015, 06:55:33 PM »
Are you sure you have it hooked to the correct port and pin ?

IS this a LPT ver of Mach3 or other controller ?

(;-) TP

Offline mike^3

*
  •  117 117
    • View Profile
Re: CNC plasma setup help :)
« Reply #6 on: May 18, 2015, 07:43:17 PM »
I think I figured it out I was only getting .5 v when the contact closed I think the limit switch is bad, swapped of switches and it works thanks for the help ;)

Offline BR549

*
  •  6,887 6,887
    • View Profile
Re: CNC plasma setup help :)
« Reply #7 on: May 18, 2015, 07:56:52 PM »
Glad you got it sorted. Those Gemlins can be tough sometimes(;-)

(;-) TP